Subject: Re: Retrieving current date

From: "[email-masked]" <[email-masked]>
Date: Thu, 19 Jun 2025 06:23:08 +0000 (UTC)

Hello,May be a very basic question.  We all here are new to Linux / PostgreSQL
Ubuntu Server 22.04PostgreSQL 15PgAdmin4 6.16
When I run the following query in pg_admin
Select today_now From   (Select localtimestamp(0) as today_now) a;
I get UTC time and not the IST time, which I expect.
How to change the setting(s), if any, to retrieve the current date and time in IST?
Happiness Always
BKR Sivaprakash

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 19 Jun 2025 07:10:54 -0700

On 6/18/25 23:23, [email-masked] wrote:
> Hello,
> May be a very basic question.  We all here are new to Linux / PostgreSQL
> 
> Ubuntu Server 22.04
> PostgreSQL 15
> PgAdmin4 6.16
> 
> Select today_now
> From   (Select localtimestamp(0) as today_now) a;
> 

For setting see:

https://www.postgresql.org/docs/current/runtime-config-client.html

"TimeZone (string)

     Sets the time zone for displaying and interpreting time stamps. The 
built-in default is GMT, but that is typically overridden in 
postgresql.conf; initdb will install a setting there corresponding to 
its system environment. See Section 8.5.3 for more information.
"

For a quick fix, maybe?:

select localtimestamp(0) at time zone 'Asia/Kolkata' as today_now;

-- 
Adrian Klaver
[email-masked]