Subject: Re: License question

From: Christophe Pettus <[email-masked]>
Date: Mon, 25 Nov 2024 22:12:09 -0800

Hello,

I think there is a fundamental misunderstanding here about how PostgreSQL's licensing works.

You do not pay for the community version of PostgreSQL.  The license specifically states it is available without a fee.  It's free.  No one collects money for the community version of PostgreSQL.

There's no "enterprise" version of PostgreSQL that is provided by the community.  It's just PostgreSQL.

There are vendors which provide either commercial versions of PostgreSQL based on the community version, or which provide commercial support for PostgreSQL, but those are separate things from the PostgreSQL community version, and you would need to talk to the individual companies to find out what their arrangements are.

> On Nov 25, 2024, at 22:04, prashant sinha <[email-masked]> wrote:
> 
> Hi Christophe,
> Thank you so much for the response. One of my client is also requesting details of licensed version of PostgreSQL. Could you please guide me cost of PostgreSQL license which they want to get installed on their (client’s) on premise server. Not sure how pricing works for enterprise license which have all associated support for enterprise. Also not sure if we can install on any supported license for on-Prem server or we have to buy specific server recommended by PostgreSQL. Will appreciate your guidance here. 
> 
> Thanks,
> Prashant 
> 
> 
> Sent from Yahoo Mail for iPhone
> 
> On Tuesday, November 26, 2024, 1:29 AM, Christophe Pettus <[email-masked]> wrote:
> 
> 
> > On Nov 21, 2024, at 21:40, prashant sinha <[email-masked]> wrote:
> > Is there a free version of PostgreSQL available which I can use without buying any licenses? In case I want to self install and manage the database? Just need guidance if I can install the available version from site for business purpose too or I must buy licenses? Will appreciate an appropriate related answer.
> 
> 
> PostgreSQL itself is an open source project distributed under a very permissive license:
> 
>     https://www.postgresql.org/about/licence/
> 
> No payment is required to download and run it.

---

From: prashant sinha <[email-masked]>
Date: Tue, 26 Nov 2024 06:46:56 +0000 (UTC)

Thank you Christophe I am very clear now. And post your email researched various vendors and will get in touch with them. 

Thanks,Prashant 

On Tuesday, November 26, 2024, 11:42 AM, Christophe Pettus <[email-masked]> wrote:

Hello,

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 26 Nov 2024 11:45:33 -0500

On Mon, Nov 25, 2024 at 10:12:09PM -0800, Christophe Pettus wrote:
> You do not pay for the community version of PostgreSQL.  The license
> specifically states it is available without a fee.  It's free.  No one
> collects money for the community version of PostgreSQL.
>
> There are vendors which provide either commercial versions of
> PostgreSQL based on the community version, or which provide commercial
> support for PostgreSQL, but those are separate things from the
> PostgreSQL community version, and you would need to talk to the
> individual companies to find out what their arrangements are.

I have blogged about this confusion:

	https://momjian.us/main/blogs/pgblog/2023.html#September_1_2023

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  When a patient asks the doctor, "Am I going to die?", he means 
  "Am I going to die soon?"