Subject: Re: Re. Select with where condition times out

From: Michael Nolan <[email-masked]>
Date: Sat, 20 Jul 2024 14:21:56 -0500

On Thu, Jul 18, 2024 at 4:38 AM [email-masked]
<[email-masked]> wrote:
>
> Hello,
> PG V11
>
> Select count(*) from table1
> Returns 10456432
>
> Select field1, field2 from table1 where field3> '2024-07-18 12:00:00'
> Times out
>
> The above query was working fine for the past 2 years.
>
> Backup was taken a day back.  Need to recover complete data as far as possible.
>
> Any possible way(s) to do this?
>
> BKR Sivaprakash
>

If you do a full backup, does it complete in a normal manner and the usual time?

Have you tried doing a shutdown and restart of the database, or
possibly rebooting the server?

You may need to alter the database server settings to increase the
maximum query time.

Mike Nolan
[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 22 Jul 2024 04:46:13 +0000 (UTC)

On Sunday, 21 July, 2024 at 12:52:22 am IST, Michael Nolan <[email-masked]> wrote:  

Mike Nolan
[email-masked]

1.  Full backup taken without any issue.  Checked it by restoring as another database in the same server.  No Issues.
2.  PG Service stopped and re-started.    Re-booted the server also.  Same issue.
3.  PG is working with default settings only, that's set during installation time.  
When the query was run in the restored database, in the same server machine, the query executed in a second.  The same query, in original database, takes more than 15 min.  
BKR Sivaprakash