Subject: Re: glibc updarte 2.31 to 2.38

From: Paul Förster <[email-masked]>
Date: Sun, 22 Sep 2024 18:48:46 +0200

Hi Joe

> On 22. Sep, 2024, at 15:47, Joe Conway <[email-masked]> wrote:
> 
> Note that moving to ICU might improve things, but there are similar potential issues with ICU as well. The trick there would be to get your OS distro provider to maintain the same ICU version across major versions of the distro, which is not the case currently. Nor does the PGDG repo do that.

Then I strongly suggest that the PostgreSQL developers develop a fail safe sorting mechanism that holds for generations of locale changes.

Cheers,
Paul

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 22 Sep 2024 09:53:58 -0700

> Then I strongly suggest that the PostgreSQL developers develop a fail safe sorting mechanism that holds for generations of locale changes.

https://www.postgresql.org/docs/17/release-17.html#RELEASE-17-HIGHLIGHTS

Add a builtin platform-independent collation provider (Jeff Davis)

This supports C and C.UTF-8 collations.

-- 
Adrian Klaver
[email-masked]

---

From: Joe Conway <[email-masked]>
Date: Sun, 22 Sep 2024 14:44:49 -0400

> This supports C and C.UTF-8 collations.

Yep, what he said

-- 
Joe Conway
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com

---

From: "Peter J. Holzer" <[email-masked]>
Date: Sun, 22 Sep 2024 21:47:25 +0200

On 2024-09-22 09:53:58 -0700, Adrian Klaver wrote:
> > Then I strongly suggest that the PostgreSQL developers develop a
> > fail safe sorting mechanism that holds for generations of locale
> > changes.
> 

Couldn't you always use "C" collation?

The problem with that is that most people[1] want stuff ordered
according to the rules of their language and C collation is in most
cases very different.

        hp

[1] I actually have LC_COLLATE=POSIX set in the shell. But I'm not
    normal.

-- 
   _  | Peter J. Holzer    | Story must make more sense than reality.
|_|_) |                    |
| |   | [email-masked]         |    -- Charles Stross, "Creative writing
__/   | http://www.hjp.at/ |       challenge!"

---

From: Paul Foerster <[email-masked]>
Date: Wed, 25 Sep 2024 09:16:20 +0200

Hi Adrian,

> On 22 Sep 2024, at 18:53, Adrian Klaver <[email-masked]> wrote:
> 

I must admit that I haven't read the readme fully yet, but this is definitely great news. Thanks very much.

Cheers,
Paul