Subject: Re: postgres in swap space

From: Adrian Klaver <[email-masked]>
Date: Mon, 17 Nov 2025 13:41:14 -0800

On 11/17/25 13:12, Ron Johnson wrote:
> On Mon, Nov 17, 2025 at 3:50 PM Laurenz Albe <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     On Mon, 2025-11-17 at 18:25 +0100, Marc Millas wrote:
>      > Can someone point me to any doc describing why and how much space
>     postgres uses on the swap of a debian machine ?
>      > it's an old postgres 10, because it is used by a product for
>     which only this version is certified.
>      > (no comment on that, please)
> 
>     I'm biting down a comment.
> 
> 
> "If it ain't broke, don't fix it" works just fine (until it doesn't).

The problem is when it doesn't work anymore, the work load to move to a 
newer version is that much greater. Keeping the version within spitting 
distance of the latest supported version, to me, is a good idea.

> 
> -- 
> Death to <Redacted>, and butter sauce.
> Don't boil me, I'm still alive.
> <Redacted> lobster!

-- 
Adrian Klaver
[email-masked]

---

From: Ron Johnson <[email-masked]>
Date: Mon, 17 Nov 2025 19:18:36 -0500

On Mon, Nov 17, 2025 at 4:41 PM Adrian Klaver <[email-masked]>
wrote:

> newer version is that much greater.

That's my point.  If it just *kept* working, there would be no problem.

> Keeping the version within spitting

As much as people love to complain about how useless PCI DSS is (see
the recent thread on TDE), there's one benefit: ensuring that companies
keep computers patched and running supported software.