Subject: Running psql in a docker container

From: H <[email-masked]>
Date: Thu, 11 Jul 2024 10:57:15 -0400

I used to successfully run psql server 13 in a CentOS 7 docker container with CentOS 7 as the host operating system. I have now upgraded that system to Rocky Linux 9 as the host operating system and modifying my container to also use Rocky Linux 9 and psql server 16.

I can successfully get the container up and running and can connect to it. However, I have not managed to modify the initdb statement to use en_US.UTF-8 for all databases.

In the old container I used:

su - postgres -c "/usr/pgsql-13/bin/initdb -D /var/lib/pgsql/13/data/ -E 'UTF-8' --lc-collate='en_US.UTF-8' --lc-ctype='en_US.UTF-8'"

but this does not work with psql 16. I tried:

su - postgres -c "/usr/pgsql-16/bin/initdb -D /var/lib/pgsql/16/data/ -E 'UTF-8' --lc-lang='en_US'"

and variations thereof with no success.

Any suggestions on what I have missed?

Thank you.

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 11 Jul 2024 08:06:02 -0700

> and variations thereof with no success.

Without a definition of what '... no success' means there is no real way 
to answer this.

-- 
Adrian Klaver
[email-masked]