Subject: libpq15 with postgres server16 and scram-sha-256

From: MM <[email-masked]>
Date: Wed, 4 Sep 2024 11:54:12 +0100

Hello
is it possible to connect with PGConnectdb version 15 to a server that has
in METHOD in pg_hba.conf   "scram-sha-256"
or do I need version libpq 16 ?

If so, being constrained to remain at 15 libpq for now, is md5 allowed?

Rds,

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 04 Sep 2024 13:24:25 +0200

On Wed, 2024-09-04 at 11:54 +0100, MM wrote:
> is it possible to connect with PGConnectdb version 15 to a server that has in METHOD in pg_hba.conf   "scram-sha-256"

You can use "scram-sha-256" authentication from v10 on.

Note that it only works if the database password is a scram-sha-256 hash, not an MD5 hash.

Yours,
Laurenz Albe