Subject: fail to install postgresql15 on Alma9

From: Dmitry O Litvintsev <[email-masked]>
Date: Tue, 18 Jun 2024 17:40:08 +0000

Hello, 

I am foillowing instructions on 

https://www.postgresql.org/download/linux/redhat/

I select version "15"
I select "Red Hat Enterprise, Rocky, AlmaLinux or or Oracle 9"

I get this command to run:

"dnf install -y https://download.postgresql.org/pub/repos/yum/reporpms/EL-9-x86_64/pgdg-redhat-repo-latest.noarch.rpm"

But then I fail to install postgersql15:

# yum install postgresql15-server 
Last metadata expiration check: 0:22:07 ago on Tue 18 Jun 2024 12:16:52 PM CDT.
No match for argument: postgresql15-server
Error: Unable to find a match: postgresql15-server

I can install postgresql16-server sussessfully but not 15. 
I need 15. What am I doing wrong?

Thank you, 
Dmitry

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 18 Jun 2024 10:44:47 -0700

> I need 15. What am I doing wrong?

I don't use RH, still the instructions here:

Mention doing:

# Disable the built-in PostgreSQL module:
sudo dnf -qy module disable postgresql

Did you do the above?

Then:

# Install PostgreSQL:
sudo dnf install -y postgresql15-server

-- 
Adrian Klaver
[email-masked]