Subject: create_immv issue on aws Ubuntu even after create extention

From: Krishnakant Mane <[email-masked]>
Date: Fri, 28 Feb 2025 22:11:41 +0530

Hello all.

I am not able to use create_immv in postgresql 16.6 even after 
installing it and doing create extention.

I did a git clone of the repository and then make sudo make install to 
install it.

The issue is not happening on my local ubuntu 24.04 machine but on 
ubuntu 24.04 on aws free tier.

All dependencies are in place, that's why the extention got installed in 
the first place.

I get the error "function create_immv(unknown, unknown) does not exist.

all the tables related to this view exist, data is present and same 
setup works perfectly on my local machine, same OS and postgresql version.

Can someone suggest what could be the solution?

Regards.

Email Signature
*Krishnakant Mane*
Software Architecture Design & Implementation Specialist 	

Mobile: 	
	+91 8424039903

https://www.linkedin.com/in/krishnakant-r-mane/

---

From: Ron Johnson <[email-masked]>
Date: Fri, 28 Feb 2025 11:54:48 -0500

On Fri, Feb 28, 2025 at 11:41 AM Krishnakant Mane <[email-masked]>
wrote:

> Hello all.
>
> I am not able to use create_immv in postgresql 16.6 even after installing
> it and doing create extention.
>
> The issue is not happening on my local ubuntu 24.04 machine but on ubuntu
> 24.04 on aws free tier.
>
> all the tables related to this view exist, data is present and same setup
> works perfectly on my local machine, same OS and postgresql version.
>
Show your work!

What command did you run to get that error?

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!