Subject: Soluton on Lock:extend issue

From: Durgamahesh Manne <[email-masked]>
Date: Sat, 10 Aug 2024 22:22:39 +0530

Hi

Lock:extend  (version 14.11)
How to resolve lock:extend issue even there is surge in concurrent sessions
(insert and update) on same table

Reduction on concurrent sessions would be solved but that is not a solution
and
there is no network bandwidth issue

Is there any parameter to tune to minimize the impact on lock:extend ?

Regards,
Durga Mahesh

---

From: Christophe Pettus <[email-masked]>
Date: Sat, 10 Aug 2024 10:15:46 -0700

> On Aug 10, 2024, at 09:52, Durgamahesh Manne <[email-masked]> wrote:

PostgreSQL version 16 contains improvements that significantly reduce the amount of contention on extend locks; upgrading will almost certainly help.