Subject: Re: Postgresql python in upgraded version 16.2

From: Adrian Klaver <[email-masked]>
Date: Thu, 20 Jun 2024 08:03:45 -0700

On 6/19/24 22:05, Šika Michal wrote:
> TLP:AMBER
> 
> 
> Hello all,
> I upgraded version of Postgres from 13.5 to newest 16.2. But Python was 
> not upgraded.
> 
> I create procedure pyver():
> CREATE OR REPLACE FUNCTION pyver ()
>   RETURNS TEXT
>   AS $$
>       import sys
>       pyversion = sys.version
>       return pyversion
>   $$ LANGUAGE 'plpython3u';
> 
> On the Postgres 13.5 I get this result:
> # psql -d database
> psql (13.5)
> Type "help" for help.
> 
> postgres@database # select pyver();
>                    pyver
> -----------------------------------------
>   3.6.8 (default, Aug 13 2020, 07:36:02) +
>   [GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]
> (1 řádka)
> 
> postgres@database #
> 
> On the Postgres 16.2 (upgraded from version 13.5) I get this result:
> # psql -d database
> psql (16.2)
> Type "help" for help.
> 
> database=# select pyver();
>                    pyver
> -----------------------------------------
>   3.6.8 (default, Jan  5 2024, 09:14:44) +
>   [GCC 8.5.0 20210514 (Red Hat 8.5.0-20)]
> (1 row)
> 
> database=#
> 
> It seems python was not upgraded when I upgrade PostgreSQL. Is possible 
> upgrade the python to actual version 3.9.x installed on RedHat 8.5 ?

Where are you getting the packages from, the Red Hat repo or the PGDG repo?

> Thanks
> Michal
> TLP:AMBER

-- 
Adrian Klaver
[email-masked]

---

From: Šika Michal <[email-masked]>
Date: Fri, 21 Jun 2024 07:33:01 +0000

Hello,
I get the install packages from this repository:
https://download.postgresql.org/pub/repos/yum/16/redhat/rhel-8.9-ppc64le/

Michal
________________________________
Od: Adrian Klaver <[email-masked]>
Odesláno: čtvrtek 20. června 2024 17:03
Komu: Šika Michal <[email-masked]>; [email-masked] <[email-masked]>
Předmět: Re: Postgresql python in upgraded version 16.2

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 25 Jun 2024 08:42:37 -0700

On 6/21/24 00:33, Šika Michal wrote:
> https://download.postgresql.org/pub/repos/yum/16/redhat/rhel-8.9-ppc64le/ <https://download.postgresql.org/pub/repos/yum/16/redhat/rhel-8.9-ppc64le/>

I would go here:

https://yum.postgresql.org/contact/

and use the Issue Tracker link.

You will need to set up a Postgres community account to access the 
tracker. Clicking on the link will guide you through the process.