Subject: PGBouncer - Load balancing options

From: Ravi Varma Addala <[email-masked]>
Date: Thu, 10 Oct 2024 10:02:15 +0000

Hello Team,
I wanted to reach out to provide some insight into a request from my customer regarding their multiple PostgreSQL Flex instances with PGbouncer. Currently, they are utilizing an Azure Load Balancer which distributes connections using the Round-robin mechanism. However, they are now seeking a solution that allows for load balancing based on the number of connections, meaning the Load Balancer should route requests to the instance with the least number of connections.
Unfortunately, Azure Standard Load Balancer does not support this capability. However, Application Gateway does offer this functionality - Microsoft.Network/applicationGateways - Bicep, ARM template & Terraform AzAPI reference | Microsoft Learn<https://learn.microsoft.com/en-us/azure/templates/microsoft.network/applicationgateways?pivots=deployment-language-bicep#applicationgatewayloaddistributionpolicypropertiesfo>

ASK:

  1.  Has anyone implemented this kind of approach and is it possible?
  2.  Can we do health probe with PostgreSQL to get no of connections metric?

  1.
Kind Regards,
Ravi Varma Addala
Cloud Solution Architect
[email-masked]<mailto:[email-masked]>

[Microsoft]

---

From: Christophe Pettus <[email-masked]>
Date: Fri, 11 Oct 2024 07:35:06 -0700

Hello,

> On Oct 10, 2024, at 03:02, Ravi Varma Addala <[email-masked]> wrote:
> 
> Hello Team,I wanted to reach out to provide some insight into a request from my customer regarding their multiple PostgreSQL Flex instances with PGbouncer. Currently, they are utilizing an Azure Load Balancer which distributes connections using the Round-robin mechanism. However, they are now seeking a solution that allows for load balancing based on the number of connections, meaning the Load Balancer should route requests to the instance with the least number of connections.Unfortunately, Azure Standard Load Balancer does not support this capability. However, Application Gateway does offer this functionality - Microsoft.Network/applicationGateways - Bicep, ARM template & Terraform AzAPI reference | Microsoft Learn
>  ASK:
> 
>     • Has anyone implemented this kind of approach and is it possible?
>     • Can we do health probe with PostgreSQL to get no of connections metric?

Even though you mention pgbouncer in the subject:, your questions tare about proprietary products that your employer provides and supports.  It's probably best to ask internally about their functionality; the community almost certainly does not have any better insight into them.