Subject: Compatibility Issues with Npgsql and .NET Framework 3.5 after Upgrading to PostgreSQL 16.3

From: 馬 騰飛 <[email-masked]>
Date: Fri, 25 Oct 2024 03:45:58 +0000

Dear PostgreSQL Community,

After upgrading PostgreSQL to version 16.3, our server encountered the error 
"Only AuthenticationClearTextPassword and AuthenticationMD5Password supported for now. Received: 10" when connecting to the database.

We are currently using .NET Framework version 3.5. If we upgrade Npgsql to version 8.0.5, will there be compatibility issues? 
If there are compatibility issues, could you tell me the minimum version of Npgsql that we should use to upgrade PostgreSQL to 16.3 without upgrading the .NET Framework?

Looking forward to your reply.

Best regards,
Coder Ma

---

From: Daniel Gustafsson <[email-masked]>
Date: Fri, 25 Oct 2024 13:58:07 +0200

> On 25 Oct 2024, at 05:45, 馬　騰飛 <[email-masked]> wrote:
> 

Try PostgreSQL 16.4 instead, there was a known regression for very old Npgsql
versions in 16.3.

--
Daniel Gustafsson