Subject: Re: Description field for tables and views

From: Kent Dorfman <[email-masked]>
Date: Wed, 3 Jul 2024 16:24:12 -0400

On 7/3/24 15:30, Christophe Pettus wrote:
>
>> On Jul 3, 2024, at 12:28, Kent Dorfman<[email-masked]>  wrote:
>>
>> Is there any psql function/command to add a description field to a table or view definition in the system?
> Allow me to introduce you to my good friend "COMMENT":
>
> 	https://www.postgresql.org/docs/current/sql-comment.html
Thanks for the hint!

It's the simplest and most direct solution.  Been typing SQL for 40 
years and haven't had occasion to use COMMENT.  Is it SQL standard or 
postgres specific?  Am not a DBA by trade but an embedded systems guy.

---

From: Christophe Pettus <[email-masked]>
Date: Wed, 3 Jul 2024 13:25:55 -0700

> On Jul 3, 2024, at 13:24, Kent Dorfman <[email-masked]> wrote:
> Is it SQL standard or postgres specific?

It's not in the SQL standard (at the bottom of each page for each SQL command is a note regarding its relationship with the SQL standard).  Other DBMS implement something similar, however.