Subject: ODBC fails to recognize event trigger removal

From: Igor Korot <[email-masked]>
Date: Sun, 23 Nov 2025 06:44:58 -0600

Hi, ALL,

[code]
postgres=# CREATE OR REPLACE FUNCTION __watch_schema_changes() RETURNS
event_trigger LANGUAGE plpgsql AS $$ BEGIN NOTIFY tg_tag; END; $$;
CREATE FUNCTION
postgres=# CREATE EVENT TRIGGER schema_change_notify ON
ddl_command_end WHEN TAG IN('CREATE TABLE', 'ALTER TABLE', 'DROP
TABLE', 'CREATE INDEX', 'DROP INDEX') EXECUTE PROCEDURE
__watch_schema_changes();
CREATE EVENT TRIGGER
postgres=# DROP EVENT TRIGGER schema_change_notify CASCADE;
DROP EVENT TRIGGER
postgres=# \q
igor@WaylandGnome ~/unixODBC-2.3.12 $ isql postgres postgres wasqra123
+---------------------------------------+
| Connected!                            |
|                                       |
| sql-statement                         |
| help [tablename]                      |
| echo [string]                         |
| quit                                  |
|                                       |
+---------------------------------------+
SQL> CREATE OR REPLACE FUNCTION __watch_schema_changes() RETURNS
event_trigger LANGUAGE plpgsql AS $$ BEGIN NOTIFY tg_tag; END; $$;
SQLRowCount returns -1
SQL> CREATE EVENT TRIGGER schema_change_notify ON ddl_command_end WHEN
TAG IN('CREATE TABLE', 'ALTER TABLE', 'DROP TABLE', 'CREATE INDEX',
'DROP INDEX') EXECUTE PROCEDURE __watch_schema_changes();
[ISQL]ERROR: Could not SQLExecute
SQL> quit
igor@WaylandGnome ~/unixODBC-2.3.12 $
[/code]

Server version 16.2
Driver version 11.1

Anybody aware of this?

Thank you.

---

From: Igor Korot <[email-masked]>
Date: Sun, 23 Nov 2025 10:17:36 -0800

Originally sent to PostgreSQL general ML.

Thank you.

---------- Forwarded message ---------
From: Igor Korot <[email-masked]>
Date: Sun, Nov 23, 2025 at 4:44 AM
Subject: ODBC fails to recognize event trigger removal
To: pgsql-generallists.postgresql.org <[email-masked]>

Hi, ALL,

[code]

Server version 16.2
Driver version 11.1

Anybody aware of this?

Thank you.