Subject: How to get the data from the query

From: "David G. Johnston" <[email-masked]>
Date: Sat, 26 Apr 2025 18:06:22 -0700

On Saturday, April 26, 2025, Igor Korot <[email-masked]> wrote:

> but the size comes out "" (empty)
>
>
What is the value you are expecting?  What is the minimal table definition
(i.e., a one or few column table) that would produce this expected value?
What does psql show if you use it to output the query against that table?

David J.

---

From: Igor Korot <[email-masked]>
Date: Sun, 27 Apr 2025 00:44:34 -0500

Hi, David,

On Sat, Apr 26, 2025 at 8:06 PM David G. Johnston
<[email-masked]> wrote:
> What is the value you are expecting?

Expecting to have "100".

  What is the minimal table definition (i.e., a one or few column
table) that would produce this expected value?

CREATE TABLE IF NOT EXISTS leagues(id integer primary key, name
varchar(100), drafttype integer, scoringtype integer, roundvalues
integer, leaguetype char(5), salary integer, benchplayers integer);
Field "name" should be 100.

draft=# SELECT column_name, data_type, character_maximum_length,
numeric_precision, table_name FROM information_schema.columns WHERE
column_name = 'name' ORDER BY tabl
e_name;
column_name |     data_type     | character_maximum_length |
numeric_precision |           table_name
-------------+-------------------+--------------------------+-------------------+---------------------------------
name        | text              |                          |
        | abcß
name        | character varying |                      100 |
        | leagues
name        | name              |                          |
        | pg_available_extension_versions
name        | name              |                          |
        | pg_available_extensions
name        | text              |                          |
        | pg_config
name        | text              |                          |
        | pg_cursors
name        | text              |                          |
        | pg_file_settings
name        | text              |                          |
        | pg_prepared_statements
name        | text              |                          |
        | pg_settings
name        | text              |                          |
        | pg_shmem_allocations
name        | text              |                          |
        | pg_stat_slru
name        | text              |                          |
        | pg_timezone_names
name        | character varying |                       70 |
        | players
name        | character varying |                       50 |
        | teams
(14 rows)

draft=#

Query is shorter, but it gives the result of 100.

Let me try the full one from my code...

Thank you.

---

From: Igor Korot <[email-masked]>
Date: Sun, 27 Apr 2025 00:53:12 -0500

Now this query still works:

[code]
draft=# SELECT DISTINCT column_name, data_type,
character_maximum_length, character_octet_length, numeric_precision,
numeric_precision_radix, numeric_scale, is_nullabl
e, column_default, ordinal_position FROM information_schema.columns
WHERE table_name='leagues' ORDER BY ordinal_position;

column_name  |     data_type     | character_maximum_length |
character_octet_length | numeric_precision | numeric_precision_radix |
numeric_scale | is_nullable | col
umn_default | ordinal_position
--------------+-------------------+--------------------------+------------------------+-------------------+-------------------------+---------------+-------------+----
------------+------------------
id           | integer           |                          |
              |                32 |                       2 |
   0 | NO          |
           |                1
name         | character varying |                      100 |
          400 |                   |                         |
     | YES         |
           |                2
drafttype    | integer           |                          |
              |                32 |                       2 |
   0 | YES         |
           |                3
scoringtype  | integer           |                          |
              |                32 |                       2 |
   0 | YES         |
           |                4
roundvalues  | integer           |                          |
              |                32 |                       2 |
   0 | YES         |
           |                5
leaguetype   | character         |                        5 |
           20 |                   |                         |
     | YES         |
           |                6
salary       | integer           |                          |
              |                32 |                       2 |
   0 | YES         |
           |                7
benchplayers | integer           |                          |
              |                32 |                       2 |
   0 | YES         |
           |                8
(8 rows)

[/code]

Thank you.

On Sat, Apr 26, 2025 at 8:06 PM David G. Johnston
<[email-masked]> wrote:
> What is the value you are expecting?  What is the minimal table definition (i.e., a one or few column table) that would produce this expected value?  What does psql show if you use it to output the query against that table?
>
> David J.
>