Subject: PQexecPrepared() question

From: Igor Korot <[email-masked]>
Date: Tue, 16 Dec 2025 19:04:21 -0800

Hi, ALL,
If I want to have strings (aka char *) as parameters fr the query,
should I send UTF-8 strings or something else?

Thank you.

---

From: Tom Lane <[email-masked]>
Date: Tue, 16 Dec 2025 22:08:37 -0500

> should I send UTF-8 strings or something else?

They should be in whatever is selected as the client_encoding
on your connection.  That goes for query strings too, and whatever
other text a client might send.

			regards, tom lane