Subject: Re: Messages o Terminal

From: Adrian Klaver <[email-masked]>
Date: Tue, 4 Mar 2025 17:13:10 -0800

On 3/4/25 22:28, Igor Korot wrote:
> Hi, ALL,
> I'm trying to execute:
> 
> [code]
>      queries.push_back( L"CREATE TABLE IF NOT EXISTS ......
> [/code]
> 
> However, when I run my profeam second tme I see n the Terminal:
> 
> [quote]
> NOTICE:  relation "abcatcol" already exists, skipping
> [/quote]
> 
> Is there any way to suppress this NOTICE message?

 From here:

https://www.postgresql.org/docs/current/runtime-config-client.html

SET set client_min_messages = <something above NOTICE>;

You could that for just the session.

> Thank you.

-- 
Adrian Klaver
[email-masked]

---

From: Igor Korot <[email-masked]>
Date: Wed, 5 Mar 2025 01:00:17 -0600

Adran,

> SET set client_min_messages = <something above NOTICE>;

Isn't NOTICE the default one?

Thank you,

---

From: Igor Korot <[email-masked]>
Date: Wed, 5 Mar 2025 01:10:36 -0600

Please ignore my previous message....

Works like a charm.

Thank you.