Subject: Re: issue with reading hostname

From: Adrian Klaver <[email-masked]>
Date: Mon, 22 Apr 2024 14:49:26 -0700

On 4/22/24 14:37, Atul Kumar wrote:
> Can we edit the socket to change the hostname in it ?

On Ubuntu 22.04 install, given:

srwxrwxrwx  1 postgres postgres    0 Apr 22 14:01 .s.PGSQL.5432=
-rw-------  1 postgres postgres   68 Apr 22 14:01 .s.PGSQL.5432.lock

The contents of .s.PGSQL.5432.lock(the file that indicates a Postgres 
instance has a lock on the socket) are:

862
/var/lib/postgresql/15/main
1713795311
5432
/var/run/postgresql

There is no hostname to be changed as you are working with a local socket.

> 
> Regards.
> 
> On Tue, Apr 23, 2024 at 2:41 AM Ron Johnson <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     On Mon, Apr 22, 2024 at 4:14 PM Atul Kumar <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         Hi,
> 
>         I have postgresql  version 15 running on centos7.
> 
>         I have below query that reads hostname from /tmp directory:
> 
>         psql postgres -A -t -p 5432 -h /tmp/ -c 'SELECT
>         pg_is_in_recovery();'
> 
> 
>     If you installed from the PGDG repository (possibly also the CENTOS
>     repos, but I'm not sure), then the domain socket also lives in :
>     /var/run/postgresql
> 
>     * I find that more expressive than /tmp.
>     * No need to specify the host when using sockets.
>     * Using a socket name makes parameterizing the hostname easier in
>     scripts.
> 
> 

-- 
Adrian Klaver
[email-masked]

---

From: Atul Kumar <[email-masked]>
Date: Tue, 23 Apr 2024 03:24:12 +0530

I mean, Once I change the hostname then how will the socket read the new
hostname ? Does it require a postgres service restart ?

---

From: "David G. Johnston" <[email-masked]>
Date: Mon, 22 Apr 2024 14:59:17 -0700

> hostname ? Does it require a postgres service restart ?
-h doesn't strictly mean hostname (the wording choice here does seem
problematic), rather it is simply a direct specification of how and
where the psql client looks for and connects to the server.  When the
specification is a filename it is that file that is used and hostname and
any other networking-related stuff is immaterial.  Though the server does
choose to borrow the port number 5432 from networking to construct the
unique name out of convenience.

David J.

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 22 Apr 2024 14:59:39 -0700

> hostname ? Does it require a postgres service restart ?

The host name of the machine?

> 
> 
> 
> On Tue, Apr 23, 2024 at 3:19 AM Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      > On Tue, Apr 23, 2024 at 2:41 AM Ron Johnson
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >     On Mon, Apr 22, 2024 at 4:14 PM Atul Kumar
>     <[email-masked] <mailto:[email-masked]>
>      >     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >         Hi,
>      >
>     [email-masked] <mailto:[email-masked]>
>