Subject: Postgresql active-active nodes in cluster

From: Vidyashree H S <[email-masked]>
Date: Thu, 9 May 2024 06:54:29 +0000

Hi,

I'm using Postgresql 15.4 version on RISCV architecture
I'm trying to implement active-active nodes in cluster, I have gone through various websites, there they have mentioned the theory concept of it. But I want to implement to verify how active-active nodes actually work.

Are there any resources which talks about Postgresql active-active node implementation? If yes, please provide me the resource information or url.

Thanks
Vidyashree H S

---

From: Kashif Zeeshan <[email-masked]>
Date: Thu, 9 May 2024 15:58:50 +0500

Hi

You can use BDR, you can have a look on the following link.

https://wiki.postgresql.org/wiki/Multimaster

Thanks
Kashif Zeeshan
Bitnine Global

On Thu, May 9, 2024 at 3:28 PM Vidyashree H S <[email-masked]>
wrote:

> I'm trying to implement active-active nodes in cluster, I have gone
> through various websites, there they have mentioned the theory concept of
> it. But I want to implement to verify how active-active nodes actually work.
>
> Are there any resources which talks about Postgresql active-active node
> implementation? If yes, please provide me the resource information or url.
>
>
> Thanks
> Vidyashree H S
>
>

---

From: Greg Sabino Mullane <[email-masked]>
Date: Thu, 9 May 2024 18:33:39 -0400

> https://wiki.postgresql.org/wiki/Multimaster

That is a pretty old page. There are other solutions, such as pgedge, but
the three most important questions when it comes to active-active
replication are:

* Do you really, really need it? (hint: the answer is no)
* What problem are you trying to solve?
* Are you really willing to suffer the tradeoffs?

Cheers,
Greg

P.S. Please upgrade to v15.7

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 9 May 2024 19:23:07 -0400

On Thu, May  9, 2024 at 06:33:39PM -0400, Greg Sabino Mullane wrote:
> That is a pretty old page. There are other solutions, such as pgedge, but the
> three most important questions when it comes to active-active replication are:
> 

Agreed, see this:

	https://momjian.us/main/blogs/pgblog/2018.html#December_24_2018

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: Vidyashree H S <[email-masked]>
Date: Fri, 10 May 2024 05:18:42 +0000

Thanks all for your inputs.

  *
Currently I'm working on active-passive(Primary and standby scenario).
  *
I'm preparing one study report on active-active node implementation which talks about active-active nodes background, theoretical explanation, implementation part which includes some trails on this. For that, I'm checking for the resources.

Thanks
Vidyashree H S
________________________________
From: Bruce Momjian <[email-masked]>
Sent: Friday, May 10, 2024 4:53 AM
To: Greg Sabino Mullane <[email-masked]>
Cc: Kashif Zeeshan <[email-masked]>; Vidyashree H S <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: Postgresql active-active nodes in cluster

Agreed, see this:

[EXT]

---

From: Vidyashree H S <[email-masked]>
Date: Mon, 13 May 2024 06:38:39 +0000

Hi,

  *
Is that multi master replication is not recommended to do ?
  *
If we can do, can I get any resource for implementing that on PostgreSQL which is open-source?

Thanks,
Vidyshree H S

________________________________
From: Vidyashree H S <[email-masked]>
Sent: Friday, May 10, 2024 10:48 AM
To: Bruce Momjian <[email-masked]>; Greg Sabino Mullane <[email-masked]>
Cc: Kashif Zeeshan <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: Postgresql active-active nodes in cluster

  *

Thanks
Vidyashree H S

Agreed, see this:

---

From: Greg Sabino Mullane <[email-masked]>
Date: Mon, 13 May 2024 10:13:54 -0400

On Mon, May 13, 2024 at 2:53 AM Vidyashree H S <
[email-masked]> wrote:

>
>    - Is that multi master replication is not recommended to do ?
>
>
No, it is not recommended, as it has a very, very narrow use case, and
comes with a lot of drawbacks. Sure, you COULD configure your car to also
be able to ride across the river like a boat, but it's far easier to use a
bridge, or a barge. And now your car is harder to care for, and has a lot
more ways in which it could break.

>
>    - If we can do, can I get any resource for implementing that on
>    PostgreSQL which is open-source?
>
> You still have not told us your use case. That can help us to guide you to
the right solution. But for totally open source solutions there are not
many out there. Here are some:

* https://github.com/JumpMind/symmetric-ds
* https://github.com/bucardo/bucardo

You can also in theory use logical replication if at least version 16:

* https://www.crunchydata.com/blog/active-active-postgres-16

Cheers,
Greg