Subject: Re: Stack Smashing Detected When Executing initdb

From: Kashif Zeeshan <[email-masked]>
Date: Sun, 23 Jun 2024 13:50:18 +0500

Hi Xu

To pinpoint the issue, please use gdb debugger to get the backtrace to
exactly find out where the error is occurring and you can then do the
required setups.

For Reference :
https://stackoverflow.com/questions/50093327/how-do-i-solve-postgresql-aborted-core-dumped-error

Thanks
Kashif Zeeshan

On Sun, Jun 23, 2024 at 12:19 PM Xu Haorong <[email-masked]> wrote:

> Hi everyone,
>
> Today I tried to build the latest devel version of PostgreSQL(commit
> 70a845c04a47645b58f8276a6b3ab201ea8ec426). The compilation was successful,
> but when I ran initdb an error occured:
>
> /usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
> The files belonging to this database system will be owned by user
> "postgres".
> This user must also own the server process.
>
> The database cluster will be initialized with locale "en_US.UTF-8".
> The default database encoding has accordingly been set to "UTF8".
> The default text search configuration will be set to "english".
>
> Data page checksums are disabled.
>
> fixing permissions on existing directory /usr/local/pgsql/data ... ok
> creating subdirectories ... ok
> selecting dynamic shared memory implementation ... posix
> selecting default "max_connections" ... 100
> selecting default "shared_buffers" ... 128MB
> selecting default time zone ... Asia/Shanghai
> creating configuration files ... ok
> running bootstrap script ... ok
> *performing post-bootstrap initialization ... *** **stack smashing
> detected** ***: terminated*
> *Aborted (core dumped)*
> *child process exited with exit code 134*
> *initdb: removing contents of data directory "/usr/local/pgsql/data"*
>
> After searching for solutions on the Internet, I disabled the stack
> smashing protector by performing
> *./configure CC='clang -fno-stack-protector'*
>
> However, the problem still exists. Is there anyone else having this issue?
>
> Regards,
> Haorong Xu
>

---

From: Kashif Zeeshan <[email-masked]>
Date: Sun, 23 Jun 2024 19:13:40 +0500

Hi Xu

You need to enable some settings for the code dump to generated.

For the settings you can use following link.
https://access.redhat.com/solutions/4896

Regards
Kashif Zeeshan

On Sun, Jun 23, 2024 at 7:07 PM Xu Haorong <[email-masked]> wrote:

> Hi Zeeshan,
>
> Thank you for helping me. I tried to analyze the core dump file, but
> unfortunately it didn't seem to have generated one. Therefore I ran initdb
> with gdb, which produced following output:
>
> Program received signal SIGPIPE, Broken pipe.
> 0x00007ffff791c574 in __GI___libc_write (fd=4, buf=0x555555636a60,
> nbytes=64) at ../sysdeps/unix/sysv/linux/write.c:26
> warning: 26 ../sysdeps/unix/sysv/linux/write.c: No such file or directory
>
> The error message clearly indicates that something like write.c is
> missing, which is included in GNU C Library. However, I found that I've
> already installed it on my computer. It also confuses me that there was no
> core dump file at all, since initdb says "Aborted (core dumped)". I'd
> really appreciate if you can give me further information.
>
> Regards,
> Haorong Xu
> ------------------------------
> *发件人:* Kashif Zeeshan <[email-masked]>
> *发送时间:* 2024年6月23日 16:50
> *收件人:* Xu Haorong <[email-masked]>
> *抄送:* [email-masked] <[email-masked]>
> *主题:* Re: Stack Smashing Detected When Executing initdb
>
> Hi Xu
>

---

From: Xu Haorong <[email-masked]>
Date: Sun, 23 Jun 2024 14:20:36 +0000

Hi Zeeshan,

Thank you for replying me. I'm aware that core dump files are not generated by default, so I did change my settings to allow them to be generated. But initdb still doesn't generate any core dump file, that's what makes this issue especially unusual.

Regards,
Haorong Xu
________________________________
发件人: Kashif Zeeshan <[email-masked]>
发送时间: 2024年6月23日 22:13
收件人: Xu Haorong <[email-masked]>; Postgres General <[email-masked]>
主题: Re: Stack Smashing Detected When Executing initdb

Hi Xu

Regards
Kashif Zeeshan

On Sun, Jun 23, 2024 at 7:07 PM Xu Haorong <[email-masked]<mailto:[email-masked]>> wrote:
Hi Zeeshan,

Thank you for helping me. I tried to analyze the core dump file, but unfortunately it didn't seem to have generated one. Therefore I ran initdb with gdb, which produced following output:

Program received signal SIGPIPE, Broken pipe.
0x00007ffff791c574 in __GI___libc_write (fd=4, buf=0x555555636a60, nbytes=64) at ../sysdeps/unix/sysv/linux/write.c:26
warning: 26 ../sysdeps/unix/sysv/linux/write.c: No such file or directory

The error message clearly indicates that something like write.c is missing, which is included in GNU C Library. However, I found that I've already installed it on my computer. It also confuses me that there was no core dump file at all, since initdb says "Aborted (core dumped)". I'd really appreciate if you can give me further information.

Regards,
Haorong Xu
________________________________
发件人: Kashif Zeeshan <[email-masked]<mailto:[email-masked]>>
发送时间: 2024年6月23日 16:50
收件人: Xu Haorong <[email-masked]<mailto:[email-masked]>>
抄送: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
主题: Re: Stack Smashing Detected When Executing initdb

Hi Xu

To pinpoint the issue, please use gdb debugger to get the backtrace to exactly find out where the error is occurring and you can then do the required setups.

For Reference : https://stackoverflow.com/questions/50093327/how-do-i-solve-postgresql-aborted-core-dumped-error

Thanks
Kashif Zeeshan

On Sun, Jun 23, 2024 at 12:19 PM Xu Haorong <[email-masked]<mailto:[email-masked]>> wrote:
Hi everyone,

Today I tried to build the latest devel version of PostgreSQL(commit 70a845c04a47645b58f8276a6b3ab201ea8ec426). The compilation was successful, but when I ran initdb an error occured:

/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

fixing permissions on existing directory /usr/local/pgsql/data ... ok
creating subdirectories ... ok
selecting dynamic shared memory implementation ... posix
selecting default "max_connections" ... 100
selecting default "shared_buffers" ... 128MB
selecting default time zone ... Asia/Shanghai
creating configuration files ... ok
running bootstrap script ... ok
performing post-bootstrap initialization ... *** stack smashing detected ***: terminated
Aborted (core dumped)
child process exited with exit code 134
initdb: removing contents of data directory "/usr/local/pgsql/data"

After searching for solutions on the Internet, I disabled the stack smashing protector by performing
./configure CC='clang -fno-stack-protector'

Regards,
Haorong Xu