Subject: Dropping connections

From: "Tarras, Tim" <[email-masked]>
Date: Wed, 26 Jun 2024 17:44:53 +0000

Hello,

I am having problems with loosing connection to a postgresql database with ESRI ArcGIS Pro. Below is what I put on the ESRI community forums but also wanted to post here to see I can get a resolution to this problem.  Thank you for any help you can provide.

Tim

I'm not sure if this is the right place but, I am having an issue with enterprise Database connections dropping to my computer. If I work with ArcPro on the server the connections do not drop. We also made a connection directly from my computer using pgAdmin and will not lose connection even when I loose it in Pro.

My system is as follows:

  1.  ArcGIS Enterprise 11.2 Single machine deployment. Server has 32GB of memory
  2.  ArcgisPro 3.3.0
  3.  Postgres 15.4 Downloaded from ESRI and on a separate server from enterprise. Server has 12 cores and 32GB of memory
  4.  Both servers are running Windows Server 2022 datacenter Version 21H2.

When the connection drops I get the following message:

Underlying DBMS error [no connection to the server::SQLSTATE=å] [xxxxxxx.xxx.GDB_Items][STATE_ID = 0]

X's replace actual names.

Working with ESRI we found the following information in the logs :

"An existing connection was forcibly closed by the remote host" where host is the PostgreSQL Server and "FATAL: terminating connection due to administrator command". The following PostgreSQL documentation provides more information about the same (https://www.postgresql.org/message-id/5665.1202148155%40sss.pgh.pa.us [postgresql.org]<https://urldefense.com/v3/__https:/www.postgresql.org/message-id/5665.1202148155*40sss.pgh.pa.us__;JQ!!CKZwjTOV!ynTEucv4RZeRFy0jb8ofk_Qs3LMS2aWNT8QSkc5n7RFIeJfgBOaUp0uAxwuQRhP0xWo5Yj51N2IcQ8R3mUaXZA$>).

At this time IT says it is not a fire wall issue as there are no rules setup for dropping connections. We are at a loss as to what the culprit is.

I will also be posting this in PostgreSQL community to get their input.

Thank you for your help with this.

This email and any files transmitted with it are confidential and are intended solely for the use of the individual or entity to which they are addressed. If you have received this email in error, please respond to the sender and delete the material from any computer and/or server. The City of Onalaska is subject to Wisconsin Statutes relating to public records. Emails sent or received by City employees are subject to these laws. Unless otherwise exempted from the public records law, senders and receivers of City email should presume that the emails are subject to release upon request, and to state record retention requirements.

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 26 Jun 2024 11:35:29 -0700

> "*An existing connection was forcibly closed by the remote host*" where 
> host is the PostgreSQL Server and "*FATAL: terminating connection due to 
> administrator command*". The following PostgreSQL documentation provides 
> more information about the same 

I see *FATAL: terminating connection due to administrator command*" and 
Windows my first thought is Windows Anti-Virus program hitting the 
Postgres server.

Is there an AV program running on the Windows Server 2022 server?

It would also be helpful to get the Postgres log entries immediately 
prior to lines you show above.

-- 
Adrian Klaver
[email-masked]

---

From: "Tarras, Tim" <[email-masked]>
Date: Wed, 26 Jun 2024 19:56:53 +0000

Windows Defender is turned off and a 3rd party AV is being used.  We did ask about that and were told that would not be the issue.  I would also think that I would be dropping the connection when I am on the Server itself which is not the case.

I have attached the log files with the Errors highlighted in Yellow Go to last page in each one. In reading the whole error the password authentication failed for the postgres user, which is not the user we are logged in as to this database.

-----Original Message-----
From: Adrian Klaver <[email-masked]>
Sent: Wednesday, June 26, 2024 1:35 PM
To: Tarras, Tim <[email-masked]>; [email-masked]
Subject: Re: [External] Dropping connections

> "*An existing connection was forcibly closed by the remote host*"
> where host is the PostgreSQL Server and "*FATAL: terminating
> connection due to administrator command*". The following PostgreSQL
> documentation provides more information about the same

I see *FATAL: terminating connection due to administrator command*" and Windows my first thought is Windows Anti-Virus program hitting the Postgres server.

It would also be helpful to get the Postgres log entries immediately prior to lines you show above.

---

From: Kashif Zeeshan <[email-masked]>
Date: Thu, 27 Jun 2024 08:47:41 +0500

Hi Tarras

Please refer to the following guide where connection was working fine with
PG and EPAS.

https://www.enterprisedb.com/docs/partner_docs/EsriArcGISProandEsriArcGISEnterprise/04-ConfiguringEsriArcGISProandEsriArcGISEnterprise/

Regards
Kashif Zeeshan

On Wed, Jun 26, 2024 at 10:45 PM Tarras, Tim <[email-masked]> wrote:

> Hello,
>
> I am having problems with loosing connection to a postgresql database with
> ESRI ArcGIS Pro. Below is what I put on the ESRI community forums but also
> wanted to post here to see I can get a resolution to this problem.  Thank
> you for any help you can provide.
>
> Tim
>
> I'm not sure if this is the right place but, I am having an issue with
> enterprise Database connections dropping to my computer. If I work with
> ArcPro on the server the connections do not drop. We also made a connection
> directly from my computer using pgAdmin and will not lose connection even
> when I loose it in Pro.
>
> My system is as follows:
>
>    3. Postgres 15.4 Downloaded from ESRI and on a separate server from
>    enterprise. Server has 12 cores and 32GB of memory
> more information about the same (https://www.postgresql.org/message-id/5665.1202148155%40sss.pgh.pa.us
> [postgresql.org]
> <https://urldefense.com/v3/__https:/www.postgresql.org/message-id/5665.1202148155*40sss.pgh.pa.us__;JQ!!CKZwjTOV!ynTEucv4RZeRFy0jb8ofk_Qs3LMS2aWNT8QSkc5n7RFIeJfgBOaUp0uAxwuQRhP0xWo5Yj51N2IcQ8R3mUaXZA$>
> ).
>
> At this time IT says it is not a fire wall issue as there are no rules
> setup for dropping connections. We are at a loss as to what the culprit is.
>
> This email and any files transmitted with it are confidential and are
> intended solely for the use of the individual or entity to which they are
> addressed. If you have received this email in error, please respond to the
> sender and delete the material from any computer and/or server. The City of
> Onalaska is subject to Wisconsin Statutes relating to public records.
> Emails sent or received by City employees are subject to these laws. Unless
> otherwise exempted from the public records law, senders and receivers of
> City email should presume that the emails are subject to release upon
> request, and to state record retention requirements.
>