Subject: Fwd: lost master password

From: Afa Jamal <[email-masked]>
Date: Sun, 9 Jun 2024 17:46:55 -0400

Sent from Gmail Mobile

---------- Forwarded message ---------
From: Afa Jamal <[email-masked]>
Date: Fri, Jun 7, 2024 at 8:13 PM
Subject: lost master password
To: <[email-masked]>

Hello
how you can help me with lost super password?

thank you

-- 
*Afa J Zada*

---

From: Kashif Zeeshan <[email-masked]>
Date: Mon, 10 Jun 2024 14:13:28 +0500

Hi

Do following

Stop pg service
Open pg_hba.conf
Put trust for authentication e.g. "local   all             all
                        trust"

Start the service
Log in using psql e.g psql -U postgres
Change the password e.g ALTER USER postgres WITH PASSWORD 'new_password';

Regards
Kashif Zeeshan
Bitnine Global