Subject: Re: tds_fdw >> Install Foreign data Wrapper on EDB Postgres to connect to SQL server database

From: Sumit Kochar <[email-masked]>
Date: Wed, 29 May 2024 17:10:25 +0000

Hi Muhammad,

Tried to install as per step2 mentioned, but got message - No package llvm-toolset-7 available.

Log reference below:

[root@hostip tds_fdw-2.0.3]# yum list installed | grep llvm-toolset
This system is not registered with Spacewalk server.
You can use rhn_register to register.
Spacewalk support will be disabled.
Repository mc-ol7-base-x86_64 is listed more than once in the configuration
Repository mc-ol7-layered-x86_64 is listed more than once in the configuration
Repository mc-ol7_tsm-8.1.13_x86_64 is listed more than once in the configuration
Repository mc-ol7-chef_client_15-x86_64 is listed more than once in the configuration
[root@hostip tds_fdw-2.0.3]#
[root@hostip tds_fdw-2.0.3]#
[root@hostip tds_fdw-2.0.3]# sudo yum install llvm-toolset-7
Loaded plugins: rhnplugin
This system is not registered with Spacewalk server.
You can use rhn_register to register.
Spacewalk support will be disabled.
Repository mc-ol7-base-x86_64 is listed more than once in the configuration
Repository mc-ol7-layered-x86_64 is listed more than once in the configuration
Repository mc-ol7_tsm-8.1.13_x86_64 is listed more than once in the configuration
Repository mc-ol7-chef_client_15-x86_64 is listed more than once in the configuration
No package llvm-toolset-7 available.
Error: Nothing to do
[root@hostip tds_fdw-2.0.3]#
[root@hostip tds_fdw-2.0.3]#

From: Muhammad Imtiaz <[email-masked]>
Sent: Tuesday, May 28, 2024 11:43 PM
To: Ian Lawrence Barwick <[email-masked]>
Cc: Sumit Kochar <[email-masked]>; [email-masked]
Subject: {EXTERNAL} Re: tds_fdw >> Install Foreign data Wrapper on EDB Postgres to connect to SQL server database

Hi , You need to install the LLVM toolset. 1)Check that if it is installed or not : yum list installed | grep llvm-toolset 2)If it is not installed, you can install it using the following command. sudo yum install llvm-toolset-7 Regards,Muhammad

Hi ,

You need to install the  LLVM toolset.

1)Check that if it is installed or not :

yum list installed | grep llvm-toolset

2)If it is not installed, you can install it using the following command.

sudo yum install llvm-toolset-7

Regards,

Muhammad Imtiaz

On Wed, 29 May 2024 at 05:27, Ian Lawrence Barwick <[email-masked]<mailto:[email-masked]>> wrote:
2024年5月29日(水) 6:10 Sumit Kochar <[email-masked]<mailto:[email-masked]>>:
>
> Installation of Foreign data Wrapper on EDB Postgres to connect to SQL server database is not working.
>
>
>
> https://github.com/tds-fdw/tds_fdw/issues/357<https://urldefense.com/v3/__https:/github.com/tds-fdw/tds_fdw/issues/357__;!!NDdRaFrjhKsg!t-kF9UHinbmu8b-lP0a7cxXvk9iocWrHWabJZytaRmbcLq4qaDB1zumrFBtMXnXur-vljJoQxz1eqIb5YfTO6y4$>
>
>
>
> Please advise if this has been encountered or a workaround is available.
(...)

> [root@hostip tds_fdw-2.0.3]# make USE_PGXS=1 install
>
> /opt/rh/llvm-toolset-7/root/usr/bin/clang -Wno-ignored-attributes -fno-strict-aliasing -fwrapv -Wno-unused-command-line-argument -O2  -I./include/ -fvisibility=hidden  -I. -I./ -I/usr/edb/as13/include/server -I/usr/edb/as13/include/internal -I/usr/libexec/edb-icu66/include/ -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include -flto=thin -emit-llvm -c -o src/tds_fdw.bc src/tds_fdw.c
>
> make: /opt/rh/llvm-toolset-7/root/usr/bin/clang: Command not found

IIRC you'll need to find and install the SCLO package for Oracle Linux
7, assuming it's
available. For CentOS it's this repository:
http://mirror.centos.org/centos/7/sclo/<https://urldefense.com/v3/__http:/mirror.centos.org/centos/7/sclo/__;!!NDdRaFrjhKsg!t-kF9UHinbmu8b-lP0a7cxXvk9iocWrHWabJZytaRmbcLq4qaDB1zumrFBtMXnXur-vljJoQxz1eqIb5wnHkTo8$> .

Regards

Ian Barwick

CONFIDENTIALITY NOTICE This e-mail message and any attachments are only for the use of the intended recipient and may contain information that is privileged, confidential or exempt from disclosure under applicable law. If you are not the intended recipient, any disclosure, distribution or other use of this e-mail message or attachments is prohibited. If you have received this e-mail message in error, please delete and notify the sender immediately. Thank you.

---

From: Kashif Zeeshan <[email-masked]>
Date: Thu, 30 May 2024 08:50:14 +0500

Hi Sumit

Please make sure Developer Toolset Repo is enable, the package is not
getting installed as its not being found due to the missing Repo.

Regards
Kashif Zeeshan
Bitnine Global

On Wed, May 29, 2024 at 10:10 PM Sumit Kochar <[email-masked]>
wrote:

> Hi Muhammad,
>
>
>
> Tried to install as per step2 mentioned, but got message - * No package
> llvm-toolset-7 available.*
>
>
>
> *Log reference below:*
>
>
>
> *[root@hostip tds_fdw-2.0.3]# yum list installed | grep llvm-toolset*
>
> *This system is not registered with Spacewalk server.*
>
> *You can use rhn_register to register.*
>
> *Spacewalk support will be disabled.*
>
> *Repository mc-ol7-base-x86_64 is listed more than once in the
> configuration*
>
> *Repository mc-ol7-layered-x86_64 is listed more than once in the
> configuration*
>
> *Repository mc-ol7_tsm-8.1.13_x86_64 is listed more than once in the
> configuration*
>
> *Repository mc-ol7-chef_client_15-x86_64 is listed more than once in the
> configuration*
>
> *[root@hostip tds_fdw-2.0.3]#*
>
> *[root@hostip tds_fdw-2.0.3]#*
>
> *[root@hostip tds_fdw-2.0.3]# sudo yum install llvm-toolset-7*
>
> *Loaded plugins: rhnplugin*
>
> *This system is not registered with Spacewalk server.*
>
> *You can use rhn_register to register.*
>
> *Spacewalk support will be disabled.*
>
> *Repository mc-ol7-base-x86_64 is listed more than once in the
> configuration*
>
> *Repository mc-ol7-layered-x86_64 is listed more than once in the
> configuration*
>
> *Repository mc-ol7_tsm-8.1.13_x86_64 is listed more than once in the
> configuration*
>
> *Repository mc-ol7-chef_client_15-x86_64 is listed more than once in the
> configuration*
>
> *No package llvm-toolset-7 available.*
>
> *Error: Nothing to do*
>
> *[root@hostip tds_fdw-2.0.3]#*
>
> *[root@hostip tds_fdw-2.0.3]#*
>
>
>
> *From:* Muhammad Imtiaz <[email-masked]>
> *Sent:* Tuesday, May 28, 2024 11:43 PM
> *To:* Ian Lawrence Barwick <[email-masked]>
> *Cc:* Sumit Kochar <[email-masked]>;
> [email-masked]
> *Subject:* {EXTERNAL} Re: tds_fdw >> Install Foreign data Wrapper on EDB
> Postgres to connect to SQL server database
>
>
>
> Hi , You need to install the LLVM toolset. 1)Check that if it is installed
> or not : yum list installed | grep llvm-toolset 2)If it is not installed,
> you can install it using the following command. sudo yum install
> llvm-toolset-7 Regards,Muhammad
>
> Hi ,
>
> On Wed, 29 May 2024 at 05:27, Ian Lawrence Barwick <[email-masked]>
> wrote:
>
> 2024年5月29日(水) 6:10 Sumit Kochar <[email-masked]>:
> >
> > https://github.com/tds-fdw/tds_fdw/issues/357
> <https://urldefense.com/v3/__https:/github.com/tds-fdw/tds_fdw/issues/357__;!!NDdRaFrjhKsg!t-kF9UHinbmu8b-lP0a7cxXvk9iocWrHWabJZytaRmbcLq4qaDB1zumrFBtMXnXur-vljJoQxz1eqIb5YfTO6y4$>
> >
> >
> >
> > /opt/rh/llvm-toolset-7/root/usr/bin/clang -Wno-ignored-attributes
> -fno-strict-aliasing -fwrapv -Wno-unused-command-line-argument -O2
> -I./include/ -fvisibility=hidden  -I. -I./ -I/usr/edb/as13/include/server
> -I/usr/edb/as13/include/internal -I/usr/libexec/edb-icu66/include/
> -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include -flto=thin -emit-llvm
> -c -o src/tds_fdw.bc src/tds_fdw.c
> >
> http://mirror.centos.org/centos/7/sclo/
> <https://urldefense.com/v3/__http:/mirror.centos.org/centos/7/sclo/__;!!NDdRaFrjhKsg!t-kF9UHinbmu8b-lP0a7cxXvk9iocWrHWabJZytaRmbcLq4qaDB1zumrFBtMXnXur-vljJoQxz1eqIb5wnHkTo8$>
> .
>
> Regards
>
> Ian Barwick
>
> CONFIDENTIALITY NOTICE This e-mail message and any attachments are only
> for the use of the intended recipient and may contain information that is
> privileged, confidential or exempt from disclosure under applicable law. If
> you are not the intended recipient, any disclosure, distribution or other
> use of this e-mail message or attachments is prohibited. If you have
> received this e-mail message in error, please delete and notify the sender
> immediately. Thank you.
>

---

From: Kashif Zeeshan <[email-masked]>
Date: Thu, 30 May 2024 08:51:03 +0500

Please refer to the following links for help

https://access.redhat.com/solutions/3500401
https://stackoverflow.com/questions/72778135/install-llvm-toolset-10-0-or-newer-in-centos7

Regards
Kashif Zeeshan
Bitnine Global

On Thu, May 30, 2024 at 8:50 AM Kashif Zeeshan <[email-masked]>
wrote:

>> Hi , You need to install the LLVM toolset. 1)Check that if it is
>> installed or not : yum list installed | grep llvm-toolset 2)If it is not
>> installed, you can install it using the following command. sudo yum install