Subject: Re: PG Unpivot ?

From: hubert depesz lubaczewski <[email-masked]>
Date: Mon, 3 Nov 2025 18:22:11 +0100

On Mon, Nov 03, 2025 at 12:18:55PM -0500, dfgpostgres wrote:
> psql (13.2, server 15.3) on linux
> 
> I think they call this "unpivot" in MSSQL ?
> 
> How can I get an sql query to return  one line per column with... an ID,
> column name and value.  the ctid for the id field is fine.
> 
> Example:
> dvdb=# create table unpivot (intcol integer, floatcol float, strcol
> varchar);
> CREATE TABLE
> dvdb=# insert into unpivot (intcol,floatcol,strcol) values
> (1,1.1,'one'),(2,2.2,'two'),(3,3.3,'three');
> INSERT 0 3
> dvdb=# select * from unpivot;
>  intcol | floatcol | strcol
> --------+----------+--------
>       1 |      1.1 | one
>       2 |      2.2 | two
>       3 |      3.3 | three
> (3 rows)
> I want 9 records returned, each row with 3 cols, 1st col is the ctid,
> second is the column name, third is the val.

I think it should work:

select u.ctid, e.* from unpivot u, to_jsonb(u) j, jsonb_each_text(j) e;

Best regards,

depesz

---

From: dfgpostgres <[email-masked]>
Date: Mon, 3 Nov 2025 12:32:09 -0500

Wow !
That did it, even with the predicate I stuck on the end when I tried it.

Thanks Depesz !