Subject: Re: Max size per relation for partitioned tables

From: "Reftel, Bengt Erik Magnus" <[email-masked]>
Date: Mon, 28 Oct 2024 09:41:36 +0000

Wednesday, 23 October 2024 at 23:48, David G. Johnston <[email-masked]> wrote:
> On Wednesday, October 23, 2024, Reftel, Bengt Erik Magnus <mailto:[email-masked]> wrote:
>> Appendix K of the documentation, https://www.postgresql.org/docs/current/limits.html, lists 32TB as the maximum
>> size of a relation, but it´s not clear to me whether “relation” in this context for a partitioned table means the entire
>> logical table, or just the individual physical tables it comprises. That distinction is kind of critical for our use-case.
>> Does anyone here know which it is?
>Each physical partition.

Thank you! I´ll try to make a change to the documentation to clarify that.

Best Regards
Magnus Reftel

________________________________
Denne e-posten og eventuelle vedlegg er beregnet utelukkende for den institusjon eller person den er rettet til og kan være belagt med lovbestemt taushetsplikt. Dersom e-posten er feilsendt, vennligst slett den og kontakt Skatteetaten.
The contents of this email message and any attachments are intended solely for the addressee(s) and may contain confidential information and may be legally protected from disclosure. If you are not the intended recipient of this message, please immediately delete the message and alert the Norwegian Tax Administration.

---

From: David Rowley <[email-masked]>
Date: Tue, 29 Oct 2024 23:42:24 +1300

> Thank you! I´ll try to make a change to the documentation to clarify that.

Perhaps a new row after the "relation size" row with "partitioned
table" and upper limit of "32TB * number of partitions" with a comment
"individual partitions cannot exceed 32TB"

David