Subject: Passwordcheck Extension Not Installing

From: Cihat Küçükbağrıaçık <[email-masked]>
Date: Sat, 8 Feb 2025 22:28:44 +0300

Hi Community,

I have a PostgreSQL 17.2 database running on Ubuntu 22.04. I'm trying to
install the passwordcheck extension, but I keep getting a "file not found"
error.

postgres=# create extension passwordcheck;
ERROR:  extension "passwordcheck" is not available
DETAIL:  Could not open extension control file
"/usr/share/postgresql/17/extension/passwordcheck.control": No such file or
directory.
HINT:  The extension must first be installed on the system where PostgreSQL
is running.

Even though I have installed the postgresql-contrib packages, I still
cannot see the extension. Below, I have listed the steps I followed. Could
you help me with this issue?

https://www.postgresql.org/docs/current/passwordcheck.html

Regards.

---

From: Guillaume Lelarge <[email-masked]>
Date: Mon, 10 Feb 2025 11:27:45 +0100

Hi,

On 08/02/2025 20:28, Cihat Küçükbağrıaçık wrote:
> install the |passwordcheck| extension, but I keep getting a "file not 
> found" error.
> 
> DETAIL:  Could not open extension control file "/usr/share/ 
> postgresql/17/extension/passwordcheck.control": No such file or directory.
> HINT:  The extension must first be installed on the system where 
> PostgreSQL is running.
> 
> 
> Even though I have installed the |postgresql-contrib| packages, I still 
> cannot see the extension. Below, I have listed the steps I followed. 
> Could you help me with this issue?
> 
> https://www.postgresql.org/docs/current/passwordcheck.html <https:// 
> www.postgresql.org/docs/current/passwordcheck.html>
> 

To install passwordcheck, you shouldn't use "CREATE EXTENSION". You need 
to add it to shared_preload_librarires, restart PostgreSQL, and that's all.

Regards.

-- 
Guillaume Lelarge
Consultant
https://dalibo.com

---

From: Cihat Küçükbağrıaçık <[email-masked]>
Date: Mon, 10 Feb 2025 18:50:48 +0300

Hi,

Thank you for your response. Yes, it turns out that it works without
needing to run *CREATE EXTENSION*. My issue has been resolved. Thank you
for your help.

Best regards.

>
> ---------- Forwarded message ---------
> Gönderen: Guillaume Lelarge <[email-masked]>
> Date: 10 Şub 2025 Pzt, 13:28
> Subject: Re: Passwordcheck Extension Not Installing
> To: <[email-masked]>
>
>
> Hi,
>