Subject: apt-archive.postgresql.org a bit broken?

From: Tomas Pospisek <[email-masked]>
Date: Fri, 5 Jul 2024 18:07:31 +0200

Hello,

I get this when I try to access the archive of focal packages:

```
# apt-get update
[...]
Err:6 https://apt-archive.postgresql.org/pub/repos/apt focal-pgdg 
InRelease
   403  Forbidden [IP: 2600:9000:2761:4600:b:5965:3380:93a1 443]
[...]
E: Failed to fetch 
https://apt-archive.postgresql.org/pub/repos/apt/dists/focal-pgdg/InRelease 
  403  Forbidden [IP: 2600:9000:2761:4600:b:5965:3380:93a1 443]
E: The repository 'https://apt-archive.postgresql.org/pub/repos/apt 
focal-pgdg InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is 
therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user 
configuration details.
```

And so I can't access old, archived focal packages. I guess this isn't 
wanted behavior?

In case I should direct this problem report to some different place I'd 
be glad if you would tell me.

Thank you,
*t

---

From: Magnus Hagander <[email-masked]>
Date: Fri, 5 Jul 2024 18:27:54 +0200

> be glad if you would tell me.

The dist name should be "focal-pgdg-archive" not "focal-pgdg".

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>

---

From: Tomas Pospisek <[email-masked]>
Date: Fri, 5 Jul 2024 19:07:02 +0200

On 05.07.24 18:27, Magnus Hagander wrote:
> 
> 
> On Fri, Jul 5, 2024 at 6:07 PM Tomas Pospisek <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Hello,
> 
>     Err:6 https://apt-archive.postgresql.org/pub/repos/apt
>     <https://apt-archive.postgresql.org/pub/repos/apt> focal-pgdg
>     InRelease
>     https://apt-archive.postgresql.org/pub/repos/apt/dists/focal-pgdg/InRelease <https://apt-archive.postgresql.org/pub/repos/apt/dists/focal-pgdg/InRelease>
>     <https://apt-archive.postgresql.org/pub/repos/apt>
You are right, thank you!
*t