Subject: Re: Unexpected data when subscribing to logical replication slot

From: Adrian Klaver <[email-masked]>
Date: Wed, 8 May 2024 08:17:29 -0700

> 
> We have found two things that appear to resolve the problem -
> 
>   * Using a more powerful EC2 instance. We can reproduce the issue with
>     a r7a.medium instance but not with a r7a.large EC2 instance.
>   * Changing the Postgres synchronous_commit parameter from "on" to
>     "off". We cannot reproduce the issue with synchronous_commit set to
>     "off".

What is running on the EC2 instance?:

1) The Postgres server.

2) The replication receiver.

3) Both.

> 
> We need help to understand this unexpected behaviour.
> 
> We are using Postgres 14.10.
> 
> Thanks,
> Daniel McKenzie

-- 
Adrian Klaver
[email-masked]

---

From: Daniel McKenzie <[email-masked]>
Date: Wed, 8 May 2024 16:24:32 +0100

It's running both (in docker containers) and also quite a few more docker
containers running various .NET applications.

Daniel McKenzie
Software Developer

Office: +1 403.910.5927 x 251
Mobile: +44 7712 159045
Website: www.curvedental.com

*Curve Dental Confidentiality Notice*
This message is intended exclusively for the individual or entity to which
it is addressed. This communication may contain information that is
proprietary, privileged, confidential, or otherwise legally exempt from
disclosure. If you are not the named addressee, you are not authorized to
read, print, retain, copy, or disseminate this message or any part of it.
If you have received this message in error, please notify the sender
immediately by replying to this e-mail and delete all copies of this
message.