Subject: Re: Direct Major Upgrade (13.7 → 17.6) with pg_upgrade: Clarifying the need for Intermediate Minor Fixes/Scripts

From: Greg Sabino Mullane <[email-masked]>
Date: Wed, 1 Oct 2025 07:26:59 -0400

On Wed, Oct 1, 2025 at 3:47 AM Vu Le (JData - HN) <[email-masked]>
wrote:

> My question is: When performing a direct jump from 13.7 to 17.6 using
> pg_upgrade, do I need to manually identify and execute the cumulative extra
> works/fixes from ALL the skipped intermediate versions (13.8, 13.9, 14.x,
> 15.x, 16.x)?
>

Yes. Although with common sense, e.g. no need to reindex something twice.

Is there an official best practice document that clarifies how
> pg_upgrade handles these "extra works" from skipped minor releases?
>

These are not handled by pg_upgrade, hence the "extra". As you noted above,
it's a manual step of reading the release notes and taking steps depending
on your particular database. Keep in mind, these steps are very rare.

Does pg_upgrade implicitly incorporate all necessary structural fixes from
> the minor versions between 13.7 and 17.6?
>

Yes

> Has anyone in the community performed a similar large jump and found
> unexpected issues due to skipping these intermediate manual steps?
>

I've jumped many versions, many times, for many clients. Just follow the
recommended steps and all will be well.

Cheers,
Greg

--
Crunchy Data - https://www.crunchydata.com
Enterprise Postgres Software Products & Tech Support

---

From: "Vu Le (JData - HN)" <[email-masked]>
Date: Wed, 1 Oct 2025 21:14:56 +0700

Hi Greg,
Much appreciated for the clear confirmation! It’s great to know that
`pg_upgrade` takes care of all structural changes, and that the
remaining "extra works" are indeed a rare manual check. I will follow
your advice and use common sense during the final review. Thanks for
the guidance and the reassurance.

On Wed, Oct 1, 2025 at 6:27 PM Greg Sabino Mullane <[email-masked]> wrote:
>
> On Wed, Oct 1, 2025 at 3:47 AM Vu Le (JData - HN) <[email-masked]> wrote:
>>
>> My question is: When performing a direct jump from 13.7 to 17.6 using pg_upgrade, do I need to manually identify and execute the cumulative extra works/fixes from ALL the skipped intermediate versions (13.8, 13.9, 14.x, 15.x, 16.x)?
>
>
> These are not handled by pg_upgrade, hence the "extra". As you noted above, it's a manual step of reading the release notes and taking steps depending on your particular database. Keep in mind, these steps are very rare.
>
>> Does pg_upgrade implicitly incorporate all necessary structural fixes from the minor versions between 13.7 and 17.6?
>
>
> Yes
>
>>
>> Has anyone in the community performed a similar large jump and found unexpected issues due to skipping these intermediate manual steps?
>
>
> I've jumped many versions, many times, for many clients. Just follow the recommended steps and all will be well.
>
> Cheers,
> Greg
>
> --

-- 
Best Regards,

Miles Le (Mr.)