Subject: Re: Fwd: Regarding tables detach concurrently with run_maintenance_proc()

From: Christoph Berg <[email-masked]>
Date: Fri, 19 Jul 2024 16:25:47 +0200

Re: Durgamahesh Manne
> with pg_partman By default proc() does not detach tables concurrently. How
> do we implement tables detach concurrently without blocking other sessions
> Here queries not using date column to detach tables with
> run_maintenance_proc() which is not using concurrently  based on the
> retention policy which leads to scan all available child tables hence need
> to trigger this proc with concurrently option to avoid blocking other child
> tables beyond rentention policy while running statements on them

You might have more success by filing pg_partman issues at
https://github.com/pgpartman/pg_partman/issues

> Do we have any other alternative rather than using pg_partman()?

Well you can just run the same commands manually that pg_partman would
run.

Christoph

---

From: Durgamahesh Manne <[email-masked]>
Date: Fri, 19 Jul 2024 20:26:37 +0530

> Well you can just run the same commands manually that pg_partman would

Hi
You might have more success by filing pg_partman issues at
https://github.com/pgpartman/pg_partman/issues     >>> okay
 My intention is to have any other extension other than pg_partman to
manage table partitions manually

Regards
Durga Mahesh

---

From: Muhammad Imtiaz <[email-masked]>
Date: Mon, 22 Jul 2024 09:59:53 +0500

Hi ,

You can consider the pg_pathman extension.

*Muhammad Imtiaz*

*PostgreSQL Technical Support Lead *
*/ Pakistan R&D*
*Mobile: +923345072521*
*Email: [email-masked] <[email-masked]>*