Subject: Moving from Linux to Linux?

From: Paul Foerster <[email-masked]>
Date: Tue, 11 Mar 2025 17:22:26 +0100

Hi,

we are considering changing the PostgreSQL platform from SUSE SLE to Red Hat. To keep service interruptions as short as possible, the idea is to set up a streaming replication from the SUSE server to be replaced to a temporary Red Hat server and then replace that SUSE server with the newly setup Red Hat server.

My idea is to set up a streaming replication for this. But this of course only works if the data files would be binary compatible.

So, I wonder, if this is possible. We have a lot of databases, some of them need to be highly available and some are large too.

Are there any obstacles that definitely make that a no-go? Do I risk corruption? It's both Linux, just a different distribution.

Cheers,
Paul

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 11 Mar 2025 16:30:29 +0000

Hi,

(Sorry for the top posting)

Streaming replication won't work between SLES and RHEL, mostly because of glibc incompatibilities. Use logical replication.

Regards, Devrim

---

From: Ron Johnson <[email-masked]>
Date: Tue, 11 Mar 2025 12:32:39 -0400

On Tue, Mar 11, 2025 at 12:23 PM Paul Foerster <[email-masked]>
wrote:

> Hi,
>
> we are considering changing the PostgreSQL platform from SUSE SLE to Red
> Hat. To keep service interruptions as short as possible, the idea is to set
> up a streaming replication from the SUSE server to be replaced to a
> temporary Red Hat server and then replace that SUSE server with the newly
> setup Red Hat server.
>
> My idea is to set up a streaming replication for this. But this of course
> only works if the data files would be binary compatible.
>
> So, I wonder, if this is possible. We have a lot of databases, some of
> them need to be highly available and some are large too.
>
> Are there any obstacles that definitely make that a no-go? Do I risk
> corruption? It's both Linux, just a different distribution.
>

The same version of PG will be on both, right?

What version of RHEL?  What version of SLES?  Those questions are proxy
for: what version of glibc on each system?

If they're the same, and you use libc for collation, then you're (probably)
good to go.

If they're different, then you should use logical replication.  Otherwise,
string collation mismatch could bite you on any indices on text fields.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!