Subject: Re: Connection Issue

From: Adrian Klaver <[email-masked]>
Date: Fri, 2 Aug 2024 09:18:52 -0700

On 8/2/24 9:00 AM, Andy Hartman wrote:
Reply to list also.
Ccing list.
> I changed to md5 and I can connect via HeideSQL interface no problem

Changed what to md5?

The issue is with Npgsql(?) though.

What is the Npgsql version?

> 
> On Fri, Aug 2, 2024 at 11:05 AM Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     On 8/2/24 07:56, Andy Hartman wrote:
>      > I'm using a Powershell script to connect to a remote 16.3(windows)
>      > version of the DB.
>      >
>      > Add-type -path 'C:\Program Files
>      > (x86)\PostgreSQL\Npgsql\bin\net451\Npgsql.dll'
>      >
>      > # Define connection strings for MS SQL and PostgreSQL
>      > $pgsqlConnectionString =
>      > "Host=xxxxxx;Port=5432;Username=xxx;Password=xx;Database=xxx;"
>      >
>      > # Create connection to PostgreSQL
>      > $pgsqlConn = New-Object Npgsql.NpgsqlConnection
>      > $pgsqlConn.ConnectionString = $pgsqlConnectionString
>      > $pgsqlConn.Open()
>      >
>      >
>      > When this statement hits I get an error:
>      >
>      > Exception calling "Open" with "0" argument(s): "Authentication
>     method
>      > not supported (Received: 10)"
> 
>     Best bet old library that does not understand scram-sha-256
>     authentication.
> 
> 
>      >
>      > Any ideas?
>      >
>      > Thanks.
> 
>     -- 
>     Adrian Klaver
>     [email-masked] <mailto:[email-masked]>
> 

-- 
Adrian Klaver
[email-masked]

---

From: Andy Hartman <[email-masked]>
Date: Fri, 2 Aug 2024 12:32:19 -0400

How can I tell that?

 Thanks.

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 2 Aug 2024 09:44:07 -0700

> How can I tell that?

I don't use NET or npgsql so I getting out of my depth here.

The first thing I would do is look at the package/installer you used to 
load npgsql for version info.

Second look at Installed Software and see if the version is reported there.

> 
>   Thanks.
> 
> On Fri, Aug 2, 2024 at 12:18 PM Adrian Klaver <[email-masked] 
>      > On Fri, Aug 2, 2024 at 11:05 AM Adrian Klaver
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >      > I'm using a Powershell script to connect to a remote
>     16.3(windows)
>      >      > version of the DB.
>      >      >
>      >      > Add-type -path 'C:\Program Files
>      >      > (x86)\PostgreSQL\Npgsql\bin\net451\Npgsql.dll'
>      >      >
>      >      > # Define connection strings for MS SQL and PostgreSQL
>      >      > $pgsqlConnectionString =
>      >      > "Host=xxxxxx;Port=5432;Username=xxx;Password=xx;Database=xxx;"
>      >      >
>      >      > # Create connection to PostgreSQL
>      >      > $pgsqlConn = New-Object Npgsql.NpgsqlConnection
>      >      > $pgsqlConn.ConnectionString = $pgsqlConnectionString
>      >      > $pgsqlConn.Open()
>      >      >
>      >      >
>      >      > When this statement hits I get an error:
>      >      >
>      >      > Exception calling "Open" with "0" argument(s): "Authentication
>      >     method
>      >      > not supported (Received: 10)"
>      >
>      >      >
>      >      > Any ideas?
>      >      >
>      >      > Thanks.
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >
> 
>     -- 
>     Adrian Klaver