Subject: Latest patches break one of our unit-test, related to RLS

From: Dominique Devienne <[email-masked]>
Date: Thu, 4 Sep 2025 17:03:25 +0200

In the same vein as v18betas breaking our unit-tests...
(we still don't understand, haven't looked much though).

OK, above it's about a major upgrade. So that's one thing.

But now, we've ascertain that a particular test is:

OK with 16.9 and 17.5 (we cannot test on beta2 anymore)
KO with 16.10 and 17.6 (and beta3 too, released at the same time)

Which for a minor patch is a surprise to us, not in a good way.

So... Did anything change around RLS in this patch series?
Anything changed around ROLE INHERIT rules?

The symptom is that a LOGIN user lacks ROLEs is used to have.
So perhaps some GRANTs are now silently doing nothing,
for some unknown reasons.

What in these patches could be affecting those areas?

Thanks, --DD

---

From: Laurenz Albe <[email-masked]>
Date: Thu, 04 Sep 2025 17:18:31 +0200

> What in these patches could be affecting those areas?

Without a reproducer, that is a wild goose chase.

Yours,
Laurenz Albe

---

From: Dominique Devienne <[email-masked]>
Date: Thu, 4 Sep 2025 17:28:41 +0200

> Without a reproducer, that is a wild goose chase.

Oh, it's easy to reproduce here...
But distilling it down is no small feat.
But this is a patch. Patches are not supposed to break things.