Subject: Re: Latest patches break one of our unit-test, related to RLS

From: Adrian Klaver <[email-masked]>
Date: Thu, 4 Sep 2025 08:12:56 -0700

On 9/4/25 08:03, Dominique Devienne wrote:
> In the same vein as v18betas breaking our unit-tests...
> (we still don't understand, haven't looked much though).
> 
> OK, above it's about a major upgrade. So that's one thing.
> 
> But now, we've ascertain that a particular test is:
> 
> OK with 16.9 and 17.5 (we cannot test on beta2 anymore)
> KO with 16.10 and 17.6 (and beta3 too, released at the same time)

How did you move from one version to the other?

> 
> Which for a minor patch is a surprise to us, not in a good way.
> 
> So... Did anything change around RLS in this patch series?
> Anything changed around ROLE INHERIT rules?
> 
> The symptom is that a LOGIN user lacks ROLEs is used to have.
> So perhaps some GRANTs are now silently doing nothing,
> for some unknown reasons.

What are the GRANTs that are done to give the user the privileges?

> 
> What in these patches could be affecting those areas?
> 
> Thanks, --DD
> 
> 

-- 
Adrian Klaver
[email-masked]

---

From: Dominique Devienne <[email-masked]>
Date: Thu, 4 Sep 2025 17:31:03 +0200

> How did you move from one version to the other?

We first upgraded in place. Broke that test.
We then re-installed fresh servers, minus-1 the latest patches.
And verified the tests ran OK again,on these.
We have several clusters on that machine.

---

From: Dominique Devienne <[email-masked]>
Date: Thu, 4 Sep 2025 17:45:41 +0200

> We first upgraded in place. Broke that test.

We're still naive I guess. And didn't expect a minor upgrade to break us...

Given this mishap, we'll do the reverse from now on.
Install fresh clusters for the new versions (minor or not), and see
what happens.
So we don't "advance" our main/primary (testing) clusters until
"issues are resolved".