Subject: Re: DISABLE TRIGGER doc wrong?

From: Adrian Klaver <[email-masked]>
Date: Mon, 25 Aug 2025 09:24:50 -0700

On 8/25/25 09:19, Dominique Devienne wrote:
> or I'm reading it wrong? --DD
> 
>  From https://www.postgresql.org/docs/current/sql-altertable.html#SQL-ALTERTABLE-DESC-DISABLE-ENABLE-TRIGGER:
>> Disabling or enabling internally generated constraint triggers requires superuser privileges
> 
> We were disabling triggers as the owner of the table just fine, no
> SUPERUSER involved. So is the doc out-of-date?

 From the sentence before the above:

"... internally generated constraint triggers, such as those that are 
used to implement foreign key constraints or deferrable uniqueness and 
exclusion constraints)."

> 
> PS: By mistake... We were ALTER TABLE {}.{} DISABLE TRIGGER ALL
>    when we meant ALTER TABLE {}.{} DISABLE TRIGGER USER
> 
> 

-- 
Adrian Klaver
[email-masked]

---

From: Dominique Devienne <[email-masked]>
Date: Mon, 25 Aug 2025 18:33:39 +0200

> used to implement foreign key constraints or deferrable uniqueness and

And? I don't see your point Adrian.
Has no bearing on the SUPERUSER requirement, in my reading.

---

From: Dominique Devienne <[email-masked]>
Date: Mon, 25 Aug 2025 19:12:50 +0200

> Has no bearing on the SUPERUSER requirement, in my reading.

OK, maybe my initial was poorly worded. Let me try again:

We were ALTER TABLE {}.{} DISABLE TRIGGER ALL as the table owner.

ALL includes "internally generated constraint triggers", FKs in our case.
Yet the doc clearly states one must be SUPERUSER to do that.

Thus the doc should say "requires owning the altered table, or have
superuser privileges", no?

Hope this is a clearer inquiry. Thanks, --DD