Subject: Re: libpq5 error

From: Paul Brindusa <[email-masked]>
Date: Tue, 8 Oct 2024 16:23:59 +0100

Hi guys,

I've just retried patching the host as we speak with no luck, I am getting
the exact same thing.
Following Devrim's guidance i've manually upgraded the repo file that came
down via dnf  and still getting the mismatch error:

Error: Transaction test error:
  file /usr/share/pgsql/postgres.bki from install of
libpq5-17.0-42PGDG.rhel9.x86_64 conflicts with file from package
postgresql-server-15.8-1.module+el9.4.0+25512+c6b50a48.x86_64
  file /usr/share/pgsql/system_constraints.sql from install of
libpq5-17.0-42PGDG.rhel9.x86_64 conflicts with file from package
postgresql-server-15.8-1.module+el9.4.0+25512+c6b50a48.x86_64

Any ideas?

On Tue, Oct 8, 2024 at 4:06 PM Adrian Klaver <[email-masked]>
wrote:

> On 10/8/24 01:01, Paul Brindusa wrote:
> >   Good morning Devrim,
> >
> > Is libpq5 an important component that needs the upgrade?
>
>  From here:
>
> https://www.postgresql.org/docs/current/libpq.html
>
> "libpq is the C application programmer's interface to PostgreSQL. libpq
> is a set of library functions that allow client programs to pass queries
> to the PostgreSQL backend server and to receive the results of these
> queries.
>
> libpq is also the underlying engine for several other PostgreSQL
> application interfaces, including those written for C++, Perl, Python,
> Tcl and ECPG. So some aspects of libpq's behavior will be important to
> you if you use one of those packages. In particular, Section 32.15,
> Section 32.16 and Section 32.19 describe behavior that is visible to the
> user of any application that uses libpq."
>
> To me that is, yes it is important.
>
> > I am wanting to try after Adrian's suggestion yesterday to see if I can
> > update the repo file first of all since it came with the rest of the
> > updates.
> >
> > If that does not solve it, I would consider disabling the package.
> >
> > On Tue, Oct 8, 2024 at 8:48 AM Devrim Gündüz <[email-masked]
> > <mailto:[email-masked]>> wrote:
> >
> >     Hi,
> >
> >     On Mon, 2024-10-07 at 08:44 -0700, Adrian Klaver wrote:
> >      > > Unknown Error occurred: Transaction test error:\n file
> >      > > /usr/share/pgsql/postgres.bki from install of
> >      > > libpq5-17.0-42PGDG.rhel9.x86_64 conflicts with file from package
> >      > > postgresql-server-15.8-1.module+el9.4.0+25512+c6b50a48.x86_64\n
> >     file
> >      > > /usr/share/pgsql/system_constraints.sql from install of
> >      > > libpq5-17.0-42PGDG.rhel9.x86_64 conflicts with file from package
> >      > > postgresql-server-15.8-1.module+el9.4.0+25512+c6b50a48.x86_64\n.
> >
> >     Ah ok. So basically it means PostgreSQL is installed from Red Hat
> >     packages, not PGDG. I would suggest you either not to use PGDG repos
> at
> >     all for consistency, or switch to PGDG repo and use our packages as a
> >     whole.
> >
> >     ...or you can edit /etc/yum.repos.d/pgdg-redhat-all.repo file, and
> add
> >
> >     exclude=libpq5
> >
> >     under the [pgdg-common] section so that dnf will ignore that.
> >
> >     Regards,
> >
> >
> >     --
> >     Devrim Gündüz
> >     Open Source Solution Architect, PostgreSQL Major Contributor
> >     Twitter: @DevrimGunduz , @DevrimGunduzTR
> >
> >
> >
> > --
> > Kind Regards,
> > Paul Brindusa
> > [email-masked] <mailto:[email-masked]>
>
> --
> Adrian Klaver
> [email-masked]
>
>

-- 
Kind Regards,
Paul Brindusa
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 8 Oct 2024 08:53:44 -0700

On 10/8/24 08:23, Paul Brindusa wrote:
> Hi guys,
> 
> I've just retried patching the host as we speak with no luck, I am 
> getting the exact same thing.
> Following Devrim's guidance i've manually upgraded the repo file that 
> came down via dnf  and still getting the mismatch error:
> 
> 

Yes show us the exact changes you made, including the file names of the 
files changed.

---

From: Paul Brindusa <[email-masked]>
Date: Tue, 8 Oct 2024 16:56:37 +0100

I just ran from the host dnf update -y pgdg-redhat-repo.
And retried dnf update -y libpq5  which comes back again with:

-- 
Kind Regards,
Paul Brindusa
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 8 Oct 2024 09:01:53 -0700

> And retried dnf update -y libpq5  which comes back again with:

That is not what Devrin suggested, go back and read:

https://www.postgresql.org/message-id/0a805069f207406b6c68a023bda5a9bbcda1db16.camel%40gunduz.org

---

From: Paul Brindusa <[email-masked]>
Date: Tue, 8 Oct 2024 18:00:38 +0100

Right, I was thinking that I would be able to get away with updating the
repo file and fixing the issue that way.
I've just checked the packages with dnf whatprovides postrgres and indeed
everything is coming down from Red Hat repos:

postgresql-15.8-1.module+el9.4.0+25512+c6b50a48.x86_64 : PostgreSQL client
programs
Repo        : @System

postgresql-15.8-1.module+el9.4.0+25512+c6b50a48.x86_64 : PostgreSQL client
programs
Repo        : appstream

If I were to move in getting the packages just from pgdg  we need just the
[pgdg-common] block?

-- 
Kind Regards,
Paul Brindusa
[email-masked]