Subject: Quick questions about postgres name?

From: "Dan Mahoney (Gushi)" <[email-masked]>
Date: Tue, 23 Sep 2025 04:06:49 +0000 (UTC)

Hey there folks,

The manual contains a "Brief History" of postgres and notes that the name 
Postgres was retained as an official name after Postgres95 added official 
SQL support, and because 95 wouldn't stand the test of time.

It makes mention of the original professor who spearheaded the project 
under a DARPA grant, but it would probably do well to know where the name 
came from.

If there's somewhere where this should be suggested, let me know.

(Wikipedia has some of this history -- 
https://en.wikipedia.org/wiki/Ingres_(database))

-Dan

--

---

From: Pavel Stehule <[email-masked]>
Date: Tue, 23 Sep 2025 06:16:20 +0200

Hi

> https://en.wikipedia.org/wiki/Ingres_(database))

I wrote an article about PostgreSQL history
https://postgres.cz/wiki/Historie_projektu_PostgreSQL

It is in Czech language, but google translator almost works for translation
from Czech to English.

There is a list of used literature

---

From: Tom Lane <[email-masked]>
Date: Tue, 23 Sep 2025 00:17:03 -0400

> under a DARPA grant, but it would probably do well to know where the name 

You should read Joe Hellerstein's recollections [1].  But tl;dr: the
origin of the name is the old INGRES database system; Postgres was
then named Post-inGres.  There are also some references to PostQUEL
referring to the ancient QUEL (QUEry Language) project [2].

			regards, tom lane

[1] https://arxiv.org/pdf/1901.01973
[2] https://en.wikipedia.org/wiki/QUEL_query_languages

			regards, tom lane

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 22 Sep 2025 21:19:32 -0700

On 9/22/25 21:06, Dan Mahoney (Gushi) wrote:
> Hey there folks,
> 
> The manual contains a "Brief History" of postgres and notes that the 
> name Postgres was retained as an official name after Postgres95 added 
> official SQL support, and because 95 wouldn't stand the test of time.
> 
> under a DARPA grant, but it would probably do well to know where the 
> name came from.
> 
> (Wikipedia has some of this history -- https://en.wikipedia.org/wiki/ 
> Ingres_(database))

A more direct link is:

https://en.wikipedia.org/wiki/Ingres_(database)

-- 
Adrian Klaver
[email-masked]

---

From: Achilleas Mantzios <[email-masked]>
Date: Tue, 23 Sep 2025 15:03:27 +0100

> referring to the ancient QUEL (QUEry Language) project [2].
I remember back in school (circa 1987) in the course of data structures, 
the topic of tree traversal using the 3 recursive methods : pre-order, 
in-order and post-order was quite popular back then, in this spirit, 
indeed, Postgres sounds like the next step of Ingres, but this is my 
sole impression !