Subject: Re: Declaring a field that is also an out parameter in a function

From: Adrian Klaver <[email-masked]>
Date: Sun, 7 Jul 2024 07:48:36 -0700

On 7/7/24 07:42, Pavel Stehule wrote:
>     I'm not sure why there's a warning about using an alias. 43.3.1 says
>     to use them for improved readability.
> 
> 
> it is obsolete - aliases were used when Postgres doesn't support named 
> arguments.

Is that was what it was complaining about or the fact they where 
declared and never used?

> 
> I  don't know any good reason why one variable can use more than one name.

Section 43.3.2. ALIAS provides the pros/cons.

> 
> There can be an exception when argument names are very long, but 
> generally they are not used.
> 
> 
> 
>     Mike Nolan
> 

-- 
Adrian Klaver
[email-masked]

---

From: Pavel Stehule <[email-masked]>
Date: Sun, 7 Jul 2024 16:53:24 +0200

> Is that was what it was complaining about or the fact they where

I am not sure if I understand the question. My  reply was related to
generic usage of aliases.

Report from plpgsql_check was correct - and related variables were not
used.

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 7 Jul 2024 08:00:51 -0700

On 7/7/24 07:53, Pavel Stehule wrote:
> 
> 
> ne 7. 7. 2024 v 16:48 odesílatel Adrian Klaver 
> <[email-masked] <mailto:[email-masked]>> napsal:
> 

The conversation was:

Mike Nolan

"I'm not sure why there's a warning about using an alias. 43.3.1 says
to use them for improved readability."

Pavel Stehule

"it is obsolete - aliases were used when Postgres doesn't support named 
arguments."

I was just trying to confirm that the warning was not for ALIAS being 
declared. That it was for what you state below.

>     [email-masked] <mailto:[email-masked]>
>

---

From: Pavel Stehule <[email-masked]>
Date: Sun, 7 Jul 2024 17:02:37 +0200

> declared. That it was for what you state below.
ok