Subject: Re: Declaring a field that is also an out parameter in a function

From: Pavel Stehule <[email-masked]>
Date: Sun, 7 Jul 2024 09:31:33 +0200

ne 7. 7. 2024 v 0:14 odesílatel Tom Lane <[email-masked]> napsal:

> Michael Nolan <[email-masked]> writes:
> > Shouldn't declaring a field that is also an OUT parameter throw an error?
>
> No.  The DECLARE is a block nested within the function,
> and the parameter is declared at function scope.
> So this is a standard case of an inner declaration masking
> an outer one.
>
> Possibly plpgsql_check can be set to complain about such cases,
> but they're legal according to the language specification.
>

yes, it does

(2024-07-07 09:27:14) postgres=# select * from
plpgsql_check_function('test_function');
┌───────────────────────────────────────────────────────────────┐
│                    plpgsql_check_function                     │
╞═══════════════════════════════════════════════════════════════╡
│ warning:00000:10:statement block:parameter "d3" is overlapped │
│ Detail: Local variable overlap function parameter.            │
│ warning extra:00000:8:DECLARE:never read variable "d3"        │
│ warning extra:00000:unused parameter "$1"                     │
│ warning extra:00000:unused parameter "$2"                     │
│ warning extra:00000:unused parameter "$3"                     │
│ warning extra:00000:unmodified OUT variable "d3"              │
└───────────────────────────────────────────────────────────────┘
(7 rows)

but looks so there are false alarms related to using an alias. It is
interesting so I have not any report about this issue, so probably using
aliases is not too common today.

Regards

Pavel

>                         regards, tom lane

---

From: Pavel Stehule <[email-masked]>
Date: Sun, 7 Jul 2024 11:13:22 +0200

> plpgsql_check_function('test_function');

I was blind, plpgsql_check is correct

Regards

Pavel

---

From: Michael Nolan <[email-masked]>
Date: Sun, 7 Jul 2024 08:01:23 -0500

On Sun, Jul 7, 2024 at 4:13 AM Pavel Stehule <[email-masked]> wrote:
>
> but looks so there are false alarms related to using an alias. It is interesting so I have not any report about this issue, so probably using aliases is not too common today.

I'm not sure why there's a warning about using an alias. 43.3.1 says
to use them for improved readability.

Mike Nolan

---

From: Tom Lane <[email-masked]>
Date: Sun, 07 Jul 2024 10:37:47 -0400

> plpgsql_check_function('test_function');

Nice!  FWIW, I think the standard terminology is "local variable
shadows function parameter".

			regards, tom lane

---

From: Pavel Stehule <[email-masked]>
Date: Sun, 7 Jul 2024 16:42:07 +0200

> to use them for improved readability.

it is obsolete - aliases were used when Postgres doesn't support named
arguments.

I  don't know any good reason why one variable can use more than one name.

There can be an exception when argument names are very long, but generally
they are not used.