Subject: PQexecParams and "SET TIME ZONE $1" gets 'syntax error at or near "$1" at character 15'

From: <[email-masked]>
Date: Sat, 23 Nov 2024 23:01:04 +0800 (CST)

I get get this same error

syntax error at or near "$1" at character 15

if I feed "const char *command" with the following texts.

SET TIME ZONE $1
SET TIME ZONE $1::TEXT

For some reasons, I can not add quotes around $1 as follows.

SET TIME ZONE '$1'
SET TIME ZONE '$1'::TEXT

Statements like "SELECT ... WHERE $1=..." have been working flawlessly.

It looks like PQexecParams doesn't handle statement with "SET ... $1". 

Are there workarounds for me or PQexecParams needs improvement?

Thank you!

---

From: Pavel Stehule <[email-masked]>
Date: Sat, 23 Nov 2024 16:57:49 +0100

Hi

> Are there workarounds for me or PQexecParams needs improvement?
This statement has no plan, and then doesn't support parametrization.

you can use a function set_config instead
https://www.postgresql.org/docs/current/functions-admin.html#FUNCTIONS-ADMIN-SET

SELECT set_config('timezone', $1, false)

Regards

Pavel

> Thank you!
>
> --- 本郵件來自HiNet WebMail ---
>