Subject: Re: Tablespace size in TB

From: Jan Karremans <[email-masked]>
Date: Sun, 3 May 2026 14:47:56 +0200

You can safely recommend pgBackRest as several PostgreSQL companies have already stepped up to take over/fork pgBackRest.

> On 3 May 2026, at 14:30, masheed ullah <[email-masked]> wrote:
> 
> The issue is, 13tb database BARMAN backup is taking 20 hours and restore takes 24 hours.
> So the main agenda is to reduce the backup time to less than 10hours.
> 
>  So does any solution/ tool I recommend to client.
> 
> . I just checked pgBeckRest has no more support, so I can not suggest it to client.
> 
> On Sun, May 3, 2026 at 3:25 PM Jan Karremans <[email-masked] <mailto:[email-masked]>> wrote:
>> My thinking would be to have the different directories on different tiers of storage.
>> 
>> Cheers,
>> Jan
>> 
>> > On 3 May 2026, at 14:21, Laurenz Albe <[email-masked] <mailto:[email-masked]>> wrote:
>> > 
>> > On Sun, 2026-05-03 at 14:10 +0200, Jan Karremans wrote:
>> >> Contrary to Oracle, a table space in PostgreSQL is a directory. And not a logical abstraction.
>> >> Moving tables from one table space to another becomes so much easier by that.
>> > 
>> > I am confused.  Yes, if you have more than a single (default) tablespace,
>> > moving tables between tablespaces becomes possible and hence easier.
>> > But why would you want to move tables between tablespaces in the first place?
>> > 
>> > Yours,
>> > Laurenz Albe
>> 
> 
> 
> 
> --
> Best Regards, 
> Masheed Ullah 
> 
>

---

From: Greg Hennessy <[email-masked]>
Date: Sun, 3 May 2026 11:54:57 -0400

Is the fact that other companies are taking
Over support for pgBackRest documented?

Sent from my iPhone

On May 3, 2026, at 8:48 AM, Jan Karremans <[email-masked]> wrote:

On Sun, May 3, 2026 at 3:25 PM Jan Karremans <[email-masked]> wrote:

Cheers,

Jan

> On 3 May 2026, at 14:21, Laurenz Albe <[email-masked]> wrote:

--

Best Regards,

Masheed Ullah

---

From: Christophe Pettus <[email-masked]>
Date: Sun, 3 May 2026 10:07:26 -0700

> On May 3, 2026, at 08:54, Greg Hennessy <[email-masked]> wrote:
> 

Just speaking for my company:

	https://github.com/pgexperts/pgxbackup

---

From: Ilya Kosmodemiansky <[email-masked]>
Date: Mon, 4 May 2026 07:55:34 +0200

Hi Greg,

> Over support for pgBackRest documented?

Making a company-branded fork is the easiest (and wrong) step. Planning how
to pick up the pgBackRest project or create a sustainable, community-driven
fork that re-establishes at least the same reputation requires longer
preparation. We all need patience.

-- 
Ilya Kosmodemiansky
CEO, Founder

Data Egret GmbH
Your remote PostgreSQL DBA team
T.: +49 6821 919 3297
[email-masked]

---

From: Christophe Pettus <[email-masked]>
Date: Sun, 3 May 2026 23:45:53 -0700

> On May 3, 2026, at 22:55, Ilya Kosmodemiansky <[email-masked]> wrote:
> Making a company-branded fork is the easiest (and wrong) step. Planning how to pick up the pgBackRest project or create a sustainable, community-driven fork that re-establishes at least the same reputation requires longer preparation. We all need patience.

Dave was quite clear that someone "picking up the pgBackRest project" was not on the table.  I don't think that avenue is open.

I would feel more sanguine about the idea that a new community-suported fork will emerge if there were an existence proof of it happening in the PostgreSQL community.  I can't think of one.

We need to tell our customers something, and "the community will ride in and maintain pgBackRest, just you wait" isn't a satisfactory answer.  We can tell clients all we want that the current pgBackRest version works just fine, they don't have to change, a community standard version will emerge, and so forth, but that falls on deaf ears.  This is a backup tool; it's second only to PostgreSQL itself in the "must work all the time" camp.  All they hear is what it says on the repo, which is "pgBackRest is no longer being maintained."

I think it more likely that an entirely new backup tool will emerge, become the de facto community standards, and then we will move off pgBackRest (and its forks) onto that.

---

From: Frank Lanitz <[email-masked]>
Date: Tue, 12 May 2026 07:40:44 +0200

> You can safely recommend pgBackRest as several PostgreSQL companies have already stepped up to take over/fork pgBackRest.

And ensure the customer is supporting developing / maintaining affords.
What's free cannot be good, isn't it? ;)

.f

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 May 2026 13:26:45 -0400

On Sun, May 3, 2026 at 11:45:53PM -0700, Christophe Pettus wrote:
>
>
> > On May 3, 2026, at 22:55, Ilya Kosmodemiansky <[email-masked]>
> > wrote:  Making a company-branded fork is the easiest (and wrong)
> > step. Planning how to pick up the pgBackRest project or create a
> > sustainable, community-driven fork that re-establishes at least the
> > same reputation requires longer preparation. We all need patience.
>
> Dave was quite clear that someone "picking up the pgBackRest project"
> was not on the table.  I don't think that avenue is open.
>
> I would feel more sanguine about the idea that a new
> community-sported fork will emerge if there were an existence proof
> of it happening in the PostgreSQL community.  I can't think of one.

That happened with pgbouncer where development stopped and a new team
picked it up.  I think Peter Eisentraut was involved.  With pgbackrest,
I think a similar thing would need to happen, but with a new name.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Do not let urgent matters crowd out time for investment in the future.

---

From: Josef Šimánek <[email-masked]>
Date: Thu, 14 May 2026 19:54:30 +0200

> I think a similar thing would need to happen, but with a new name.

I think David is back and no fork is needed currently.
https://github.com/pgbackrest/pgbackrest/commit/b93a2b8807adabec02ef33cca838e30f109c3eba

---

From: Ron Johnson <[email-masked]>
Date: Thu, 14 May 2026 14:03:53 -0400

On Thu, May 14, 2026 at 1:55 PM Josef Šimánek <[email-masked]>
wrote:
[snip]

> https://github.com/pgbackrest/pgbackrest/commit/b93a2b8807adabec02ef33cca838e30f109c3eba

xkcd 2347

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Josef Šimánek <[email-masked]>
Date: Thu, 14 May 2026 20:06:00 +0200

čt 14. 5. 2026 v 20:04 odesílatel Ron Johnson <[email-masked]> napsal:
>
> On Thu, May 14, 2026 at 1:55 PM Josef Šimánek <[email-masked]> wrote:
> [snip]
>>

quoting from the message

"We should also be able to bring on another maintainer to distribute
the workload and provide continuity in the future." to prevent that

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 May 2026 15:56:38 -0400

> https://github.com/pgbackrest/pgbackrest/commit/b93a2b8807adabec02ef33cca838e30f109c3eba

Well, the pgbackrest website doesn't say that:

	https://pgbackrest.org/

I thought updating that would have been the first thing done if the
status changed.

---

From: Josef Šimánek <[email-masked]>
Date: Thu, 14 May 2026 22:10:41 +0200

> I thought updating that would have been the first thing done if the

Website was also updated, but seems not deployed.
https://github.com/pgbackrest/website/commit/5516003b0f19900fe702b8afd1bc70bc16fede43
I have reported.

---

From: Josef Šimánek <[email-masked]>
Date: Fri, 15 May 2026 03:09:08 +0200

> https://github.com/pgbackrest/website/commit/5516003b0f19900fe702b8afd1bc70bc16fede43

site is updated now https://pgbackrest.org/