Subject: Upgrading from v12.7 to v15.7

From: Yongye Serkfem <[email-masked]>
Date: Mon, 8 Jul 2024 14:52:30 -0400

Hello Engineers,
After upgrading from v12.7 to v15.7, I ran the following command and got
this error message.

postgres_upgrade_work_area]$ /usr/pgsql-15/bin/pg_upgrade \
> --check \
--old-datadir=/data/postgres12 \
> --old-datadir=/data/postgres12 \
> --new-datadir=/data/postgres \
> --old-bindir=/usr/pgsql-12/bin \
> --new-bindir=/usr/pgsql-15/bin \
> --old-options '-c config_file=/data/postgres12/postgresql.conf' \
> --new-options '-c config_file=/data/postgres/postgresql.conf' \
> --old-port=5433 \
> --new-port=5432
Performing Consistency Checks on Old Live Server
------------------------------------------------
Checking cluster versions                                   ok
Checking database user is the install user                  ok
Checking database connection settings                       ok
Checking for prepared transactions                          ok
Checking for system-defined composite types in user tables  ok
Checking for reg* data types in user tables                 ok
Checking for contrib/isn with bigint-passing mismatch       ok
Checking for user-defined encoding conversions              ok
Checking for user-defined postfix operators                 ok
Checking for incompatible polymorphic functions             ok
Checking for presence of required libraries                 fatal

 Your installation references loadable libraries that are missing from the

new installation.  You can add these libraries to the new installation,
or remove the functions using them from the old installation.  A list of
problem libraries is in the file:

/data/postgres/pg_upgrade_output.d/20240708T141557.291/loadable_libraries.txt

 Failure, exiting

[postgres@AWPPLCOLEDBXL01 postgres_upgrade_work_area]$ ll
total 0
[postgres@AWPPLCOLEDBXL01 postgres_upgrade_work_area]$ cat
/data/postgres/pg_upgrade_output.d/20240708T141557.291/loadable_libraries.txt
could not load library "$libdir/cstore_fdw": ERROR:  could not access file
"$libdir/cstore_fdw": No such file or directory
In database: postgres
In database: logicole
could not load library "$libdir/oracle_fdw": ERROR:  could not access file
"$libdir/oracle_fdw": No such file or directory
In database: postgres
In database: logicole

Does anyone know where I can download rpm cstore_fdw and oracle_fdw. I have
searched and can't find the rpm for v15.7.

I will greatly appreciate any help.

---

From: Ruben Morais <[email-masked]>
Date: Mon, 8 Jul 2024 20:57:04 +0100

Hi,

Cstore -https://github.com/citusdata/cstore_fdw

Oracle_fdw -
https://github.com/laurenz/oracle_fdw/releases/tag/ORACLE_FDW_2_6_0

On Mon, Jul 8, 2024, 19:52 Yongye Serkfem <[email-masked]> wrote:

> Does anyone know where I can download rpm cstore_fdw and oracle_fdw. I
> have searched and can't find the rpm for v15.7.
>