Subject: Re: Bypassing Directory Ownership Check in PostgreSQL 16.6 with Secure z/OS NFS (AT-TLS)

From: Laurenz Albe <[email-masked]>
Date: Wed, 16 Jul 2025 17:48:10 +0200

On Wed, 2025-07-16 at 18:54 +0530, Amol Inamdar wrote:
> I would like to rephrase the question a little bit, below is how our setup going to be 
>    1. NFS mount point is for /nfs-mount/postgres (and permissions locked down so
>       that Postgres cannot create directories in here)
>    2. Postgres data directory is /nfs-mount/postgres/db
>    3. With secured NFS + AT-TLS setup Postgres will be able to write to data directory
>       but not parent dir, however the file ownership information Postgres sees from the
>       stat() call will not match the Postgres user in the container (even though the
>       AT-TLS strict access control will ensure only the Posgres user can read/write to
>       this directory)
> Considering the above scenario/setup, what is the danger of removing the ownership check
> in miscinit.c checkDataDir() function ? 

The danger is that somebody else than the PostgreSQL user has permissions on
the data directory.  You will argue that that somebody is root, and root has
these permissions anyway.

But there is another reason why PostgreSQL insists that the PostgreSQL user
owns the data directory: at startup, the postmaster checks if the data
directory belongs to the current user and fails if not.  This is a protection
against starting the postmaster with the wrong user.

There are certainly ways to do it differently, but I'd argue that they would
be more complicated, and the current simple solution is robust.

If you pre-create the data directory with the appropriate permissions,
what keeps you from giving ownership to the correct user too?

Yours,
Laurenz Albe

---

From: Amol Inamdar <[email-masked]>
Date: Thu, 17 Jul 2025 10:22:37 +0530

@Laurenz Albe <[email-masked]>
If you pre-create the data directory with the appropriate permissions,
what keeps you from giving ownership to the correct user too?

Our NFS server is not a regular linux based server,
it's on zOS (Mainframes) with AT-TLS security enabled,
hence it doesn't allow changing of ownership.

Basically, we have tried everything we could
to change the directory ownership to match with the postgres user
and that as of now looks impossible, unless we make changes in the
environment.

To summarize*, we are not able to change the ownership of the data
directory *
*due to the Mainframe NFS server limitations when enabled with AT-TLS
security *
*Hence we wanted to check if bypassing this check is ok if it could be
assured *
*that only the postgres user can write here (NFS-AT-TLS ensures that). *

I wouldn't get into details of explaining why changing ownership is not
possible,
as that would take this discussion to another context, hence avoiding.

Thanks in advance

-- 
-regards
Amol

---

From: Tom Lane <[email-masked]>
Date: Thu, 17 Jul 2025 01:14:33 -0400

> hence it doesn't allow changing of ownership.

Not only is that not a fit storage substrate for Postgres,
it's pretty hard to imagine that it's a fit substrate for
anything.  "Every file on this filesystem must belong to the
same owner" is a concept that should have gone out with
floppy disks.

You need some extremely fundamental re-examination of your
design decisions.  At the moment I am content to say that
Postgres does not support this storage mechanism and we
do not intend to do so in the future.

			regards, tom lane