Subject: Re: Foreign Data Wrapper behavior?

From: Adrian Klaver <[email-masked]>
Date: Fri, 11 Oct 2024 08:59:28 -0700

On 10/11/24 04:08, Koen De Groote wrote:
> In the release notes for postgres 17 I'm reading:
> 
>  > The PostgreSQL foreign data wrapper (postgres_fdw), used to execute 
> queries on remote PostgreSQL instances, can now push EXISTS and IN 
> subqueries to the remote server for more efficient processing.
> 
> I'm confused as to what this means. In older versions, are parts of 
> queries not sent to the foreign server? Or is this change meant to imply 
> the sending of only the subqueries, the result of which is then directly 
> used in pushing the entire query?
> 
> Or am I still wrong as to what this means?
> 
> I looked at the documentation and there doesn't seem to be any 
> indication of particular queries not being pushed to the foreign server, 
> so this wording that "can now push EXISTS and IN subqueries to the 
> remote server" is confusing.
> 
> What am I missing?

Read:

https://www.postgresql.org/docs/current/postgres-fdw.html#POSTGRES-FDW-REMOTE-QUERY-OPTIMIZATION

F.36.5. Remote Query Optimization

As to the change in the Release Note see the --hackers discussion:

https://www.postgresql.org/message-id/c9e2a757cf3ac2333714eaf83a9cc184%40postgrespro.ru

> Regards,
> Koen De Groote

-- 
Adrian Klaver
[email-masked]

---

From: Koen De Groote <[email-masked]>
Date: Sat, 12 Oct 2024 20:32:04 +0200

Ah, thanks for that