Subject: Query regarding support of test_decoding and PGReplicationStream with Standby Logical Replication

From: Kiran K V <[email-masked]>
Date: Fri, 11 Jul 2025 23:09:38 +0530

Hi,

I have a question regarding the new feature introduced in PostgreSQL 16
that enables logical replication from a standby server.

Currently, we are using a standalone instance of PostgreSQL 16 and
performing logical replication by creating replication slots and utilizing
the JDBC replication stream API (PGReplicationStream)  with the
test_decoding plugin.

Could you please confirm whether this approach of logical replication is
supported from a standby system? Specifically, does the standby system
support the test_decoding plugin and the JDBC PGReplicationStream API for
streaming changes ?

Reference to JDBC Logical replication -
https://jdbc.postgresql.org/documentation/server-prepare/#example-96-create-logical-replication-stream

Regards,
Kiran

---

From: "DINESH NAIR" <[email-masked]>
Date: Tue, 15 Jul 2025 18:13:44 +0000

Hi Kiran,

Are we trying to perform logical replication from create replication slots on a standby server and use logical decoding plugins(JDBC PGReplicationStream API) to stream changes from the standby
Is  my understanding correct?

            Hi,

I have a question regarding the new feature introduced in PostgreSQL 16 that enables logical replication from a standby server.

Currently, we are using a standalone instance of PostgreSQL 16 and performing logical replication by creating replication slots and utilizing the JDBC replication stream API (PGReplicationStream)  with the test_decoding plugin.

Could you please confirm whether this approach of logical replication is supported from a standby system? Specifically, does the standby system support the test_decoding plugin and the JDBC PGReplicationStream API for streaming changes ?

Reference to JDBC Logical replication - https://jdbc.postgresql.org/documentation/server-prepare/#example-96-create-logical-replication-stream

Regards,
Kiran

Thanks

Dinesh

________________________________
From: Kiran K V <[email-masked]>
Sent: Friday, July 11, 2025 11:09 PM
To: [email-masked] <[email-masked]>
Subject: Query regarding support of test_decoding and PGReplicationStream with Standby Logical Replication

You don't often get email from [email-masked]. Learn why this is important<https://aka.ms/LearnAboutSenderIdentification>
Caution: This email was sent from an external source. Please verify the sender’s identity before clicking links or opening attachments.
Hi,

I have a question regarding the new feature introduced in PostgreSQL 16 that enables logical replication from a standby server.

Currently, we are using a standalone instance of PostgreSQL 16 and performing logical replication by creating replication slots and utilizing the JDBC replication stream API (PGReplicationStream)  with the test_decoding plugin.

Could you please confirm whether this approach of logical replication is supported from a standby system? Specifically, does the standby system support the test_decoding plugin and the JDBC PGReplicationStream API for streaming changes ?

Reference to JDBC Logical replication - https://jdbc.postgresql.org/documentation/server-prepare/#example-96-create-logical-replication-stream

Regards,
Kiran

---

From: Kiran K V <[email-masked]>
Date: Wed, 16 Jul 2025 06:23:49 +0530

Hi Dinesh,

Yes, that is correct.

Regards,
Kiran

On Tue, Jul 15, 2025 at 11:43 PM DINESH NAIR <[email-masked]>
wrote:

>
> Hi Kiran,
>
> Are we trying to perform logical replication from create replication slots
> on a standby server and use logical decoding plugins(JDBC
> PGReplicationStream API) to stream changes from the standby
> ------------------------------
> *From:* Kiran K V <[email-masked]>
> *Sent:* Friday, July 11, 2025 11:09 PM
> *To:* [email-masked] <[email-masked]>
> *Subject:* Query regarding support of test_decoding and
> PGReplicationStream with Standby Logical Replication
>
> You don't often get email from [email-masked]. Learn why this is
> important <https://aka.ms/LearnAboutSenderIdentification>
> Caution: This email was sent from an external source. Please verify the
> sender’s identity before clicking links or opening attachments.
> Hi,
>