Subject: Re: Windows installation problem at post-install step

From: Adrian Klaver <[email-masked]>
Date: Mon, 22 Jul 2024 13:18:52 -0700

On 7/22/24 13:15, Ertan Küçükoglu wrote:
> Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>>, 22 Tem 2024 Pzt, 22:56 tarihinde 
> şunu yazdı:
> 
> 
>     Why not use that?
> 
> There was already an installed PostgreSQL just failing to start.
> I used that localization tool and it started again.
> This was the production system where Windows update changed the name of 
> the Turkish localization.
> 
> I am trying to set myself a development and testing system now.
> I lost my old VMs and need to install PostgreSQL fresh.
> Unfortunately, the installer has issues. No cluster being initialized, 
> no service is installed.

It would seem to me the process would be:

1) Create Windows VM

2) Run the localizer tool in the VM to get the old locale name in place.

3) Run the installer.

> Restoring a Windows backup into Linux system failed due to encoding 
> problems.
> 
> I cannot clone from production systems. They are using different 
> virtualization.
> My internet connection cannot handle the raw disk image transfer anyway.
> 
> Thanks & Regards,
> Ertan
> 

-- 
Adrian Klaver
[email-masked]

---

From: Ertan Küçükoglu <[email-masked]>
Date: Mon, 22 Jul 2024 23:34:19 +0300

Adrian Klaver <[email-masked]>, 22 Tem 2024 Pzt, 23:18 tarihinde

> 2) Run the localizer tool in the VM to get the old locale name in place.

I just tested that and failed at the same step.

My understanding is
- The installer has localization options to choose from or default
localization (which is Turkish_Türkiye.1254 in new VMs, it was
Turkish_Turkey.1254 in the past).
- I cannot make the installer select something else other than
Turkish_Türkiye.1254 it is hardcoded in it. So Turkish_Turkey.1254 cannot
be selected in the installer even if it is installed in the OS.
- Even if I can add a new locale to the OS, I cannot make it the default.

Thanks & Regards,
Ertan

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 22 Jul 2024 13:50:18 -0700

On 7/22/24 13:34, Ertan Küçükoglu wrote:
> <mailto:[email-masked]>>, 22 Tem 2024 Pzt, 23:18 tarihinde 
> şunu yazdı:
> 
> Turkish_Türkiye.1254 it is hardcoded in it. So Turkish_Turkey.1254 
> cannot be selected in the installer even if it is installed in the OS.

How about taking:

C:\Windows\System32\cscript //NoLogo "C:\Program 
Files\PostgreSQL\16/installer/server/initcluster.vbs" "NT 
AUTHORITY\NetworkService" "postgres" "****" 
"C:\Users\User1\AppData\Local\Temp/postgresql_installer_cd79fad8b7" 
"C:\Program Files\PostgreSQL\16" "C:\DATA_PG16" 5432 "Turkish,Türkiye"

and changing  "Turkish,Türkiye" to "Turkish_Turkey.1254"