Subject: Re: Pgsql 16 to 14 using builtin logical

From: Asad Ali <[email-masked]>
Date: Sat, 26 Oct 2024 23:38:18 +0500

I missed to mentioned in the last.

On Sat, Oct 26, 2024, 10:51 PM Adrian Klaver <[email-masked]>
wrote:

> On 10/26/24 10:06, Asad Ali wrote:
> >
> > In the typical upgrade scenario, replication flows from the lower
> > (older) version to the higher (newer) version. Here, the source is the
> > older version (e.g., PostgreSQL 14), and the target is the newer version
> > (e.g., PostgreSQL 16).
>
> So how does that fit with your statement?:
>
> "PostgreSQL's built-in logical replication allows for replicating data
> between different versions of PostgreSQL, provided the source version is
> higher than or equal to the target version."
>
> >
> > Replicating from a higher version (PostgreSQL 16) to a lower one
> > (PostgreSQL 14) is possible but unconventional and not usually done for
> > upgrades.
> >
> >
> > Best Regards,
> > Asad Ali
> >
>
> --
> Adrian Klaver
> [email-masked]
>
>

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 26 Oct 2024 14:15:56 -0700

> I missed to mentioned in the last.

?

---

From: rajesh kumar <[email-masked]>
Date: Sat, 26 Oct 2024 17:53:18 -0400

I have tested it around 3 - 4 years ago.
Logical replication is backward compatible as well.

So 16 to 14 does work :)