Subject: Re: Review my steps for rollback to restore point

From: Ron Johnson <[email-masked]>
Date: Tue, 4 Mar 2025 10:37:53 -0500

Chandran,

   1. For PITR, you should use a tool like PgBackRest.  It handles all
   $PGDATA and WAL archiving.  It's multithreaded, too,
   2. pg_restore is just for logical backups.
   3. Streaming Replication is for *hot standby*, not backups.

On Tue, Mar 4, 2025 at 10:00 AM chandan Kumar <[email-masked]>
wrote:

> Thank you for your answer.  I want to clarify one more doubt.  Can PITR be
> achieved without applying Base Backup
>
> On Tue, Mar 4, 2025 at 3:12 PM Laurenz Albe <[email-masked]>
> wrote:
>
>> On Tue, 2025-03-04 at 14:26 +0530, chandan Kumar wrote:
>> > Hello,
>> >  I hope you are doing fine. I need your expertise on below case study.
>> > My current production environment is 2 node streaming replication
>> hosted on
>> > Ubuntu VM 's on Azure. I have performed below steps on primary database.
>> > 1- Take Base backup
>> > 2-  Create a restore point using pg_create_restore_point()
>> > 3-  executed some DDL statement (CREATE VIEW,ADD INDEX,DROP INDEX)
>> > 4-  Perform rollback using restore point
>> >  To rollback, you must stop PostgreSQL, restore the last full backup,
>> and apply
>> >  WAL files until the restore point:
>> > 1. Stop PostgreSQL Service
>> > 2. Restore from Full Backup (Using pg_basebackup)
>>
> [snip]
-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: chandan Kumar <[email-masked]>
Date: Tue, 4 Mar 2025 21:12:54 +0530

Thank you !

On Tue, Mar 4, 2025 at 9:08 PM Ron Johnson <[email-masked]> wrote:

>> Thank you for your answer.  I want to clarify one more doubt.  Can PITR
>> be achieved without applying Base Backup
>>

-- 
*With warm regards*
*     Chandan*