Subject: [ANNOUNCE] BISCUIT – A Bitmap-Based Indexed Search Extension for PostgreSQL

From: Sivaprasad <[email-masked]>
Date: Sun, 2 Nov 2025 12:28:41 +0530

Hi all,

I'm excited to announce the release of BISCUIT, a new PostgreSQL
extension focused on
deterministic pattern matching using bitmaps and logical operations.

Unlike pg_trgm, BISCUIT is deterministic — no verification required.
It uses bitmap-based indexing to accelerate complex LIKE and pattern
queries with
significant performance gains.

Available on PGXN: https://pgxn.org/dist/biscuit/
Source & Docs: https://github.com/crystallinecore/biscuit

Key features:
- Bitmap-based indexed pattern matching
- Deterministic and exact results
- Works seamlessly with PostgreSQL indexing
- Lightweight, portable C extension

Feedback and contributions are welcome!

Best regards,
Sivaprasad Murali
Author, BISCUIT Extension

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 2 Nov 2025 07:21:05 -0800

> Hi all,

FYI, this:

https://www.postgresql.org/list/pgsql-announce/

"Announcement list pertaining to PostgreSQL and various third party 
software."

is the announcement list.

-- 
Adrian Klaver
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 2 Nov 2025 07:27:06 -0800

> is the announcement list.

My mistake. I see you sent to --announce also after I got a bounce on 
that list from my reply.

---

From: Sivaprasad <[email-masked]>
Date: Sun, 2 Nov 2025 22:30:09 +0530

No problem, thanks!